cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
marekbuban
Level: Powered On

InvalidTemplate error on Send email

I'm getting this weird error on Office 365 Outlook connector as well as on Mail connector.

If I recreate flow it works for few minutes and after a while it just throws this error and never works again.

Any idea what is it caused by? Other actions within same flow works fine, also same action works fine in other flows.

 

My flow is pretty simple, it gets triggered from PowerApps, it then gets item from SharePoint list and send e-mail notification including some properties from SHP item in the e-mail body.

 

sendemailerror.png

8 REPLIES 8
Super User
Super User

Re: InvalidTemplate error on Send email

Hi @marekbuban 

 

Delete the association connection for Outlook in the Flow and re-create it

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Community Support Team
Community Support Team

Re: InvalidTemplate error on Send email

 

Hi @marekbuban ,

 

Please try to export this Flow as .zip file and import it as new Flow.

After configuring the connection, this error will be ruled out.

Please take a try and feel free let us know if the issue still exists.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
marekbuban
Level: Powered On

Re: InvalidTemplate error on Send email

Hi @v-bacao-msft ,

 

yes, this will resvolve the problem, did that before, but first this is not proper solution. I did it twice yesterday. The connection is working for about hour and then same issue occurs again. Second, I also have to then update my PowerApp to use newly imported flow instead of the old corrupted one.

I don't understand why's this happening, I didn't touch the flow, nothing has changed, it just stops working Smiley Frustrated

marekbuban
Level: Powered On

Re: InvalidTemplate error on Send email

Thanks @RezaDorrani , but that didn't work for me Smiley Sad

Super User
Super User

Re: InvalidTemplate error on Send email

Hi @marekbuban 

 

Is there some MFA or Intune policy which forces user credentials tokens to be times out?

Community Support Team
Community Support Team

Re: InvalidTemplate error on Send email

 

Hi @marekbuban ,

 

For your question, please try replacing Send an email (V2) action with Send an email action and reconfiguring the Apps and Flow.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
marekbuban
Level: Powered On

Re: InvalidTemplate error on Send email

Thanks @v-bacao-msft, but that didn't work either. Same issue with V1 as with V2....

marekbuban
Level: Powered On

Re: InvalidTemplate error on Send email

@RezaDorrani I don't think so, it's only happening in few particular flows (when trigger is from PA), while it works fine in many other flows.

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020.

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 71 members 3,455 guests
Recent signins:
Please welcome our newest community members: