cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Issue loading Data to SharePoint Person field

I am trying to load data of PowerApp Apps in our organization to SharePoint list. There are few apps where the creator of the app left the organization and the apps are now orphan. I have created a Person field to store the owner of the PowerApp. Now my flow is failing when SharePoint looks up for Person who no more exist. I want to update the column value as blank if the user is not found in the organization. Please suggest a solution how to handle this.

Error:

The specified user xxxxxxx could not be found.\r\nclientRequestId: c09171b2-27bc-45cc-a737-c8f26f98a0c5\r\nserviceRequestId: c09171b2-27bc-45cc-a737-c8f26f98a0c5"
7 REPLIES 7
Microsoft
Microsoft

I am just wondering if a global  admin login and add a co owner to an  existing app should resolve your issue ? Please let me know .  

Thanks for your response @ajdhingr . We have around thousands of Apps and i have created a flow to load the data to SharePoint. This flow is now failing as the SharePoint did not find the app owners who left the organization. 

Hi Lakshman - In that case it seems difficult to find the solution but I will do some investigation and will get back. 

Hi  Laksman _ The only solutionI think  is that if your Flow is failing then you may have Apps details also. I reckon its one time effort but its worth changing the owner and in your case you may consider power-shell script to change the owner quickly and efficiently ..Please check this link: https://medium.com/@ipradeep/how-to-change-powerapps-owner-using-powershell-4a2e96baa22d . Hopefully it will help 

Hi @ajdhingr, we are not worried about the owners of the app and we are not trying to update the owner of the Orphan Apps. I am just trying to load the data to Sharepoint and the flow is getting failed. Please let me know if there is a solution

 

Thanks

Lakshman

Hi Lakshman ,

 

Can you please share the Action card in edit mode which is failing ?

Hi @ajdhingr , Thanks for looking into this issue. I have tried this way. I inserted "Search for users" and if the user is found, it loads the data to person field and if the user is not found, it loads the data with empty field. It is working fine for me.

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (7,957)