cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
wojcika
Helper II
Helper II

Item does not exist. It may have been deleted by another user.

I am new to MS Flow. I have created a very basic flow to approve items that have been added to my SP list. However, I am getting the following error during the step "update item to pending approval". 

 

{
"error": {
"code": 502,
"source": "flow-apim-msmanaged-na-centralus-01.azure-apim.net",
"clientRequestId": "b36daaa1-afe9-43d0-a5ad-1290f2f08fa9",
"message": "BadGateway",
"innerError": {
"status": 500,
"message": "Item does not exist. It may have been deleted by another user.\r\nclientRequestId: b36daaa1-afe9-43d0-a5ad-1290f2f08fa9\r\nserviceRequestId: 5350c99e-20ef-8000-5e67-9718806fc29e"
}
 
I have done a bit of research on the issue but have been unable to resolve it myself. I have included a screen shot of the flow details.
flow.png
1 ACCEPTED SOLUTION

Accepted Solutions
v-bacao-msft
Community Support
Community Support

Hi @wojcika ,

 

Could you share the screenshots of Flow configuration?

I want to know where two IDs you configured in the screenshot are from.

 

I noticed that List Name of Get Current values and Update Item to Pending Approval action are not the same.

If you use the ID generated by Get current values action to configure Update Item to Pending Approval action, you may have the problem mentioned because IDs of the two Lists are inconsistent.

 

You could try to fill the correct Dynamic content in ID field.

 

Please take a try.

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-bacao-msft
Community Support
Community Support

Hi @wojcika ,

 

Could you share the screenshots of Flow configuration?

I want to know where two IDs you configured in the screenshot are from.

 

I noticed that List Name of Get Current values and Update Item to Pending Approval action are not the same.

If you use the ID generated by Get current values action to configure Update Item to Pending Approval action, you may have the problem mentioned because IDs of the two Lists are inconsistent.

 

You could try to fill the correct Dynamic content in ID field.

 

Please take a try.

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hello,

You are correct I had two different lists selected in my Flow which was causing my issue. All is working now. 

 

Thanks!

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (68,162)