cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mel_hudson
Frequent Visitor

Key Value not working?

New to Flows and trying to build a flow from Excel Sharepoint file to Create a Calendar Invite...I cant get past the Key Value section, when I tested yesterday I would get "value" in the Apply to Each but nothing seems to work now. 

Have I misunderstood how Key Column and Value work? I tried entering HB with no luck.

Capture1.PNGpic1

 

Capture2.PNG

3 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Super User
Super User

Re: Key Value not working?

You'll want to use List rows present in a table to utilize dynamic parameters and an apply to each loop. Get a row is for a single row that you explicitly specify, so an Apply to each loop is not required. 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Community Support
Community Support

Re: Key Value not working?

 

Hi @mel_hudson ,

 

As Brad_Groux suggested, you need to get all the rows using List rows present in a table action and iterate using Apply to each.

Image reference:

43.PNG

Please try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Dual Super User
Dual Super User

Re: Key Value not working?

Hey @mel_hudson 

 

The excel date time data works a little differently in power automate. You might want to check my post on how you can work with it here: https://www.bythedevs.com/post/working-with-date-time-data-of-excel-in-power-automate

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

5 REPLIES 5
Dual Super User
Dual Super User

Re: Key Value not working?

Hey @mel_hudson 

 

Can you share some details on the scenario that you are trying to build? 

 

Note that the Get a Row action gets you a single row that matches the key column and key value that you provide. (For example in your case that you have provided the column by selecting from the dropdown, if you enter HB3 there it will get that particular row only. ) and as you are getting just one row, there is nothing to loop over on for the apply to each. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Super User
Super User

Re: Key Value not working?

You'll want to use List rows present in a table to utilize dynamic parameters and an apply to each loop. Get a row is for a single row that you explicitly specify, so an Apply to each loop is not required. 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Community Support
Community Support

Re: Key Value not working?

 

Hi @mel_hudson ,

 

As Brad_Groux suggested, you need to get all the rows using List rows present in a table action and iterate using Apply to each.

Image reference:

43.PNG

Please try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

mel_hudson
Frequent Visitor

Re: Key Value not working?

Thanks - understand how this is working now.

 

Next blockers is the date not working on the event...off to read about this now too. Great community to learn from.

"String was not recognized as a valid DateTime.
clientRequestId: 8e7c2a20-3fcd-4840-874f-84a85016129a"

Dual Super User
Dual Super User

Re: Key Value not working?

Hey @mel_hudson 

 

The excel date time data works a little differently in power automate. You might want to check my post on how you can work with it here: https://www.bythedevs.com/post/working-with-date-time-data-of-excel-in-power-automate

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Users online (5,810)