cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Kudo Collector
Kudo Collector

Looping through an array to create approvals

I am trying to loop through an array of email addresses to create several approvals. It does not seem to work. I am looking for guidance on how to accomplish this. Is it possible? Do other people get the same behavior/error? 

 

Flow

error.png

 

Error

Request to Azure Resource Manager failed with error: '{"error":{"code":"InvokerConnectionOverrideFailed","message":"Could not find any valid connection for connection reference name 'shared_approvals' in APIM tokens header."}}'.

 

Thanks!

#PowerAddicts #Flownauts

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User III
Super User III

Re: Looping through an array to create approvals

Hello @schuess3 

 

Please try and not use the "Test" button. Try triggering the flow normally.





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips, tricks, and guides
FlowAltDelete




View solution in original post

5 REPLIES 5
Highlighted
Super User III
Super User III

Re: Looping through an array to create approvals

Hello @schuess3 

 

What is your trigger?

 

How are you trigger the flow? If you’re using the test button at the top and using test from previous run. This is where the problem is.


Basically if you have any new connections since the previous run. It will fail since that previous run does not have that connection.

 

Please try and trigger the flow without test button.





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips, tricks, and guides
FlowAltDelete




Highlighted
Post Prodigy
Post Prodigy

Re: Looping through an array to create approvals

Can you try something like below and see if it works and use that variable?

 

PrasadAthalye_0-1596569706203.png

 

Highlighted
Kudo Collector
Kudo Collector

Re: Looping through an array to create approvals

@Jcook I was using the Test button, and I may be getting somewhere. The flow was also inside a solution which has given me problems in the past. I will report back with updates. 

Highlighted
Community Support
Community Support

Re: Looping through an array to create approvals

Hi @schuess3,

 

You could try to create a new connection of the SharePoint, if it not work, you could try to use another account with the same connection. Or you could also try to clear your browser cache and re-creating the connection.

If it still not work, you could consider directly contacting MS Support to solve this problem, it seems this is a back-end issue.

38.PNG

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted
Super User III
Super User III

Re: Looping through an array to create approvals

Hello @schuess3 

 

Please try and not use the "Test" button. Try triggering the flow normally.





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips, tricks, and guides
FlowAltDelete




View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (6,849)