cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
scotth82
Helper II
Helper II

MS Flows - Copy SharePoint file - Special Characters not working correctly

Hi,

 

I have a flow which after several actions copies a file from a template and renames it for the current week.

 

Something appears to be going wrong when renaming the file as it's not allowing me to use "&" in the file name but if I rename the file manually it allows me to use "&".

 

Please can you help?

 

flow.PNG

 

Thanks

 

Scott

2 REPLIES 2
v-yamao-msft
Community Support
Community Support

Hi @scotth82,

 

According to your description, I created a simple flow with the action Copy file to test this issue.

 

When configuring the flow, I added the character & between the file name and the current date. Please check the following screenshot.

1.PNG

 

When the flow was triggered, it ran succeed. However, I found that the character & was replaced with _ in the library.

2.PNG

 

You said that it was going wrong, what’s the error message? Please take it for a reference and try again on your side.

 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel,

 

That's the problem.

 

I'm trying to understand why "&" gets replaced with "_".

 

Thanks

 

Scott

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (5,348)