cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
shnurich
Helper III
Helper III

Mails connectors

Hello, 

 

I need your assistance, got a strange issue.

 

I have a custom form based on the sharepoint. It has a button that launches a flow with multiple connectors.

One of them is sending a letter to the responsible users of the process, nothing complicated.

After a while, a problem arose: these letters began to be sent not on behalf of the technical user, but on behalf of the user who clicks the button.

This bug began to slip through more and more often. I have no idea how to fix this.

Mails option: From (Send as) is blank

 

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
jinivthakkar
Dual Super User
Dual Super User

@shnurich I think you should try parent-child flow, it will definitely.

 

View solution in original post

3 REPLIES 3
jinivthakkar
Dual Super User
Dual Super User

@shnurich flow runs in the context of the user that's why the email is sent from the user who clicks the button, a good practice is to have a service account(with never expiring password, MFA disabled etc) and make the service account the owner of the flow and associate the send email action connection to service account and this should work.

 

OR you could also try a parent-child flow even this should resolve the issue.

https://docs.microsoft.com/en-us/power-automate/create-child-flows

 

Hope this helps.

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

this is done, there is a technical user who owns both the form and the flow, and the connector is tied to this account.

But from time to time, letters go not on behalf of the technical user, but from the user who pressed the button. It's kind of weird.

can you tell me more about how best to customize this technical user? maybe I missed something with never expiring password, MFA disabled etc

jinivthakkar
Dual Super User
Dual Super User

@shnurich I think you should try parent-child flow, it will definitely.

 

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Users online (3,102)