cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bentoro
New Member

Manually triggered flow: "there's a problem with the flow's trigger"

An error suddenly appeared whenever a button in a Canvas Power App triggers a flow that I have made.

 

"InvokerConnectionOverrideFailed. Failed to parse invoker connections from trigger 'manual' outputs. Exception: Could not find any valid connection for connection reference name 'shared_sharepointonline' in APIM tokens header."

 

The trigger had been working fine for months and suddenly this error has appeared. I have tried duplicating the flow and updating the Power App, and then it works temporarily. When I log out and log in again, it no longer works.

 

Could someone explain how to fix this issue?Screenshot 2020-11-07 161753.png

6 REPLIES 6
Jcook
Super User III
Super User III

Hello @bentoro 

 

You are going to want to remove the flow from the power app. And than re add the flow again.


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Brad_Groux
Super User II
Super User II

Verify that your SharePoint online connection is still logged in and valid via the Data > Connections menu: 

Connections.png

 Check our SharePoint connector(s) are Connected:

SharePointOnlineOffilineConnections.png

Even if it is Connected, it may be worth refreshing it.

If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE. Want to know more? Follow @BradGroux on Twitter, and check out my Medium blog at https://msft.engineer.

Hudson
Microsoft
Microsoft

Hey @bentoro ,

 

Hope you are doing well.

 

When a flow is added to a PowerApps, the connections that the flow uses are remembered by the PowerApps. If the flow is later updated to have more connections, the PowerApps does not know about it and doesn’t send all the connections that we need.

 

Try to remove the flow from the PowerApps, saving the app, closing the app, reopening the app( preferably in a new tab), re-adding the flow and resaving to make PowerApps notice the new connections and check if it works?

 

This is our official documentation about best practices to updating a flow used by a PowerApps for your reference:
https://support.microsoft.com/en-us/help/4477072/best-practices-updating-a-flow-used-by-a-powerapp

 

Thanks,

Hudson

Hello @Jcook,

 

Thanks for your reply.

 

I have tried this approach and it does work temporarily, but upon logging out and logging on, or publishing the changes, it breaks again with the same error.

Hello @Hudson,

 

Thanks for your reply.

 

Unfortunately, this only produces the temporary fix I described previously. I tried following your exact steps and, while it does seem to work to begin with, I tried again this morning and the same error described in my post has come up again.

 

I think it may have something to do with me publishing the Power App but I am not entirely sure.

 

Should I consider duplicating the current (canvas) Power App?

DroningOn
Helper I
Helper I

I'm also dealing with this error and it is incredibly frustrating, especially because the "flow" I'm using has an approval stage in it. How is this not being considered a bug by the Microsoft Team?

Helpful resources

Announcements
March Update

Join Stephen Siciliano and the Power Automate team at MBAS

Make sure you are registered #MSBizAppsSummit #CommunityRocks

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors
Users online (58,951)