cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Microsoft Flow & Dynamics CRM: Condition = Lookup Field Value

Hi all, 

 

Sorry if this is a really basic question but I'm a bit stumped. 

 

I'm creating a flow to perform an action when a particular dynamics record is created or updated. So I have added my trigger, condition and action. The condition doesn't seem to be working. 

 

The field on which I am basing my condition is a lookup field in dynamics so I'm wondering if the value should be the text as it shows on the record or something else? 

 

Thanks in advance. 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Thanks, I have managed to solve by inputting the GUID in the condition value for sites, without the get record. 

Thanks again for your time. 

View solution in original post

6 REPLIES 6
Highlighted
Super User III
Super User III

Hi @Jenn_0014 

 

Could you please post your flow condition?



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted

Of course. My flow runs successfully but doesn't pick up the record which meets the condition. I have attached the flow, the successful run and the record which meets the conditionFLOW - Conditional Value.pngFLOW - Success.pngFLOW.png

Highlighted

Hi,

 

Add another Get Record  (Sites Entity) before the IF Condition and pass the id from the current trigger. The only you can retrieve the text of the lookup value.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted

I am now receiving the error:

"status": 404,
"message": "new_sites With Id = 47787506-2fec-e911-a811-000d3a24ed81 Does Not Exist",
 
Thanks in advance
Highlighted

Hi @Jenn_0014 

 

I don't think that GUID is not 12-4-4-4-12 format? Is this the correct id you using?

 

47787506-2fec-e911-a811-000d3a24ed81

 

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted

Thanks, I have managed to solve by inputting the GUID in the condition value for sites, without the get record. 

Thanks again for your time. 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (9,643)