cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
nelsonbj
Level: Powered On

Microsoft Flow using both SharePoint and Excel

Good afternoon,

 

I am trying to create a flow that takes data from Microsoft Excel, determines whether this data needs to be created as a new SharePoint item, or if it already exists in SharePoint, and just needs to be updated, before finally sending a confirmation email when finished.

 

It is not the most complicated flow in the world, but for some reason, each time I try to test the workflow, I receive a "input array is empty" message and the flow stops.  Any thoughts as to what I am forgetting to include or where I am going wrong?

 

I have included a screenshot of what I have thus far, plus another screenshot showing what happens whenever I try to run the flow and receive the "input array is empty" message.  To determine whether or not a new SharePoint item is needed, I took a common field from Excel and SharePoint and simply asked the system to look for a match.  This flow seemed so easy at first, but I am completely stumped.  Any help would be greatly appreciated!!Picture2.pngPicture1.png

2 REPLIES 2
Community Support Team
Community Support Team

Re: Microsoft Flow using both SharePoint and Excel

Hi @nelsonbj,

 

Could you provide the details of your SharePoint list, is it initially an empty list?

The reason I want to see this issue is that there is no item in the SharePoint list.

If you want to use the Value of Get items in Apply_to_each, please make sure there is at least one item in the SharePoint List.

You could manually add an item to the list in advance, and then delete it after adding a new item.

Please take a try and let me know if issue still exists.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
nelsonbj
Level: Powered On

Re: Microsoft Flow using both SharePoint and Excel

It was originally an empty list... and as soon as I added a test item to the SharePoint List, Flow realizes that the condition is not empty and completes the rest of the actions.  However, now whenever I run this flow, I see a lot of duplicate items...  Does this have something to do with the "Apply to Each" condition?  And how could I get rid of the Apply to Each to ensure that this flow is only runs once?

 

Thanks for your help and quick reply!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (7,011)