cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BGSASMITH
Frequent Visitor

Microsoft Forms & Freshdesk - The response is not in a JSON format.

Hi all,

 

I'm trying to build a flow which will create a ticket within Freshdesk when a user completes a Microsoft Form.

 

When using the Freshdesk Connector with the action 'Create a new ticket' I encounter the following error. 'The response is not in a JSON format.'

 

Please see picture; https://ibb.co/BTpZfJF

 

Has anybody resolved this issue before? 

 

If you need any more information please don't hesitate to ask. I'm sure you can tell I'm new to PowerAutomate.

 

Kind regards

1 ACCEPTED SOLUTION

Accepted Solutions
manuelstgomes
Super User II
Super User II

Hi @BGSASMITH 

 

That's an issue between Power Automate and Freshdesk when trying to connect.

 

Try the following. Go to the Data > Connections and try to set up the connection there. If there's an issue with the link, you'll know right away. If not, then you can use this connection on your Power Automate, knowing that the connection is correct.

 

Can you please try this so that we can separate the issue and see where it comes from?

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Cheers
Manuel

View solution in original post

5 REPLIES 5
manuelstgomes
Super User II
Super User II

Hi @BGSASMITH 

 

That's an issue between Power Automate and Freshdesk when trying to connect.

 

Try the following. Go to the Data > Connections and try to set up the connection there. If there's an issue with the link, you'll know right away. If not, then you can use this connection on your Power Automate, knowing that the connection is correct.

 

Can you please try this so that we can separate the issue and see where it comes from?

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Cheers
Manuel

View solution in original post

Hi Manuel,

 

Thank you for your reply.

 

I've gone to Data > Connections and located the faulty Freshdesk Connection.

 

I've ensured the URL, email address and password are all correct however I receive this Red Exclamation mark with no more detail!

 

It seems like there's an issue authenticating but why I'm unsure.

 

Please see image; https://ibb.co/44hJXRZ

 

Any more ideas?

 

Kind regards, Adam

Strange, I have a flow setup to create a ticket within freshdesk and can't see any issues with it. We created it some time back but I'm sure it's still working. 

Yea my connector to freshdesk and forms is working just fine. 

 

Are you using the Freshdesk PowerAutomate connector to create a ticket?

That is what I'm trying to do yes however I'm getting the JSON error when trying to add the Freshdesk connector. 

 

What format is your URL in? I've been trying 'helpdesk.myworkplace.com' and then using an email address and password that can authenticate with the URL mentioned.

 

Thank you, Adam

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Users online (12,913)