cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
stormin_30
Helper I
Helper I

Missing column names in Create HTML table action

Hi All,

 

I have a Create HTML table action that uses "Custom" columns from the previous Filter array action. I am expecting to see the column names from the Filter array action but they are not available. I have built this identical Flow before and the columns were there.

 

Not working:

stormin_30_0-1611271177953.png

Working:

stormin_30_2-1611271224013.png

 

Is anyone else experience this behaviour using the Create HTML table action? Any insights would be appreciated.

 

Thanks.

 

Norm

1 ACCEPTED SOLUTION

Accepted Solutions
Paulie78
Super User
Super User

I believe that is the expected behaviour. You have a couple of options:

  1. Use a Parse JSON step after the filter and supply it a sample of the filtered data OR
  2. In the value column use the syntax item()['fieldName'] 

Does that make sense?

View solution in original post

2 REPLIES 2
Paulie78
Super User
Super User

I believe that is the expected behaviour. You have a couple of options:

  1. Use a Parse JSON step after the filter and supply it a sample of the filtered data OR
  2. In the value column use the syntax item()['fieldName'] 

Does that make sense?

View solution in original post

Hi @Paulie78,

 

item()?['fieldName'] worked!

 

Thanks, I appreciate it.

 

Norm

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,350)