cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
DataFailure
Level: Powered On

Missing teams channels in flow step

I'm building a Flow that uses the 'Post a message (Preview)' step and when I select the channel drop down not all of the channels of that team are appearing in the list. The account I am using to build the Flow is a dedicated account for running Flows used by my team, this dedicated account is also one of the owners of Teams. 

 

I've tried to use the 'enter custom value' option in the channel drop down and have pasted in the URL taken from the 'get link to channel' menu in teams - but this has not worked either. In a different Flow I built two days ago that also uses the 'Post a message (Preview)' step one of the channel names has turned into an alphanumeric string ending in @thread.skype and that Flow is now failing at this step. 

 

Weirdly, if I use my personal account, rather than the dedicated account to try and create a Flow that uses the 'Post a message (Preview)' step all the channels appear for the Teams that I'm looking for. Both accounts are owners in Teams.  

 

All the flows are constructed in an identical manner. The issue seems to be around the dedicated account but I'm at a loss for what it could be or how to fix it. Does anyone have any ideas as how to make the missing channel appear (or at least be able to connect to it) or have you run into a similar issue?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Missing teams channels in flow step

Hi @DataFailure ,

 

If you can configure the connection of the action using the dedicate account you mentioned, you could use the following method to configure Channel field.

Similar to your method, click Enter custom value to manually enter the channel id. This requires the channel id instead of the link to channel.

We could get the specified channel id through the List channels action.

 

Image reference:37.PNG

 

38.PNG

 

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support Team
Community Support Team

Re: Missing teams channels in flow step

Hi @DataFailure ,

 

If you can configure the connection of the action using the dedicate account you mentioned, you could use the following method to configure Channel field.

Similar to your method, click Enter custom value to manually enter the channel id. This requires the channel id instead of the link to channel.

We could get the specified channel id through the List channels action.

 

Image reference:37.PNG

 

38.PNG

 

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,189)