cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Monthly Recurrence flow not triggering

I have a recurrence trigger set for 1x/ month. When I set it with a start date/ time a few minutes ahead of now, for testing, it does not run. I think it should run. What is the flow not triggered at the time I set?  See below for the recurrence trigger setup:RecurrencceIssues.JPG

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
AKRogers
Helper V
Helper V

Hi @Anonymous,

 

Try putting the start time into UTC time.  I had the same trouble as you did with days, weeks and months until I accounted for UTC.  The recurrence seems to fire at whatever start time you provide in UTC time, regardless of the timezone you enter above it.

 

Let me know how it goes!

 

Ashley

If this response provided an answer to your question please mark it as a solution so that others can find it.

If you found this helpful, consider giving it a thumbs up!

View solution in original post

Anonymous
Not applicable

@AKRogers   Yes, that worked, thank you!! 😊

View solution in original post

5 REPLIES 5
Jcook
MVP

Hello, the answer in this postis very descriptive and get a better understanding on Flows UTC time format and issues.

 

https://powerusers.microsoft.com/t5/I-Found-A-Bug/Issues-with-scheduling-action/td-p/94771

 


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





AKRogers
Helper V
Helper V

Hi @Anonymous,

 

Try putting the start time into UTC time.  I had the same trouble as you did with days, weeks and months until I accounted for UTC.  The recurrence seems to fire at whatever start time you provide in UTC time, regardless of the timezone you enter above it.

 

Let me know how it goes!

 

Ashley

If this response provided an answer to your question please mark it as a solution so that others can find it.

If you found this helpful, consider giving it a thumbs up!

Anonymous
Not applicable

@AKRogers   Yes, that worked, thank you!! 😊

Fantastic, happy to help!

 

Ashley

Hi @AKRogers ,

 

I have tried changing to UTC as suggested but still the trigger doesn't fire. Am not sure where am going wrong, I have three flows set at different times and none of them work. I have to keep manually triggering them, this is the third day, any ideas?

Screenshot_20200510-083115_Flow.jpg

 

Helpful resources

Announcements
Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (4,565)