cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MBach20
Frequent Visitor

Multiple attachment approval workflow - problem

Hi there 

 

I am wondering whether someone can help with this approval workflow which should include all attachments to the list item. When an item is created, get all attachments and start and wait for approval - however, you get a first approval email with 1 attachment; and then once approved, a second email arrives with 2 of the attachments, and then a third email with 3 attachments, etc. We need all the attachments to come through on a single approval email. Also, when you click the attachment on the approval email, it does not seem to read / preview the document (it appears to be corrupted). Could someone kindly give some insight to where we could be going wrong? Flow screenshots attached below.

 

Many thanks

MicrosoftTeams-image (1).pngMicrosoftTeams-image (2).pngMicrosoftTeams-image.png

1 ACCEPTED SOLUTION

Accepted Solutions
ChristianAbata
Super User
Super User

hi @MBach20  this is because your approval action is inside apply to each, please create your approval outside apply to each.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

View solution in original post

3 REPLIES 3
ChristianAbata
Super User
Super User

hi @MBach20  this is because your approval action is inside apply to each, please create your approval outside apply to each.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Thank you for your reply @ChristianAbata! That has worked!

Unfortunately I still cannot figure out why the attachments don't work on the approval email. The screenshot below is the coding which we have used. Two of the attachments open as blanks and one opens with the error message below. All three attachments are fine when uploaded to the Sharepoint list. 

 MicrosoftTeams-image (3).png

MicrosoftTeams-image (4).png

Once again, thank you for your help!

oooo @MBach20  I see please try to mark this post as solution and  open a new one to keep order, tag me and I'll post in there 😉



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Users online (1,838)