cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
danielep
New Member

Multiple attachments from an Email

Hello,

I'm trying to build a flow that send an email when I receive another email in a specific folder. I know I could use simply the Outlook rules but unfortunately I can't redirect email in the final recipient + other reasons.

 

I've read lots of post about multiple attachments but always from Sharepoint and never triggered by another email.

 

My flow is like that:

 

Capture1.PNG

Capture2.PNG

 

Capture3.PNG

 

In the append to array the content is the following:

 

{
"Name": body('Get_attachment_(V2)')?['name'],
"ContentBytes": body('Get_attachment_(V2)')}
}

 

The flow doesnt give any errors however it doesnt work, I mean it's successfull when I run it but nothing happens. Anyone can help me?

 

 

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
abm
Super User III
Super User III

Hi @danielep 

 

Thanks for the response.

 

If you are happy with the response mark it as accepted solution. This will help others who are looking for solutions.



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials

View solution in original post

5 REPLIES 5
abm
Super User III
Super User III

Hi @danielep 

 

You are mapping the wrong dynamic field for ContentBytes (Append to array variable). Remove the body mapping and set the ContentBytes.

 

attachment.png

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials

I also tried with ContentBytes but still not working

abm
Super User III
Super User III

Hi @danielep 

 

Thanks for your reply. Could you please post the error you getting.

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials

Now it seems work. Thaaaanks

abm
Super User III
Super User III

Hi @danielep 

 

Thanks for the response.

 

If you are happy with the response mark it as accepted solution. This will help others who are looking for solutions.



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials

View solution in original post

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (74,079)