cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
irocha
Helper I
Helper I

My Group Form does not have a Form ID

Hello Power Automate Community,

 

I have been trying to create a flow and link my existing group form into the flow. When I look at my group form URL, it does not have a 'FormID=,' so I cannot link the form to my flow. I have even tried adding the 'id=' identifier, which has just resulted in an error with 'invalid form id.' 

1 ACCEPTED SOLUTION

Accepted Solutions
ScottShearer
Super User
Super User

@irocha 

Your screen shot shows that you still have a loop.  Please remove the loop and be sure to select the ID from the trigger when configuring your Get Response Details action.

Your Flow should look something like this:

image.png

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

7 REPLIES 7
ScottShearer
Super User
Super User

@irocha 

Please see this post as it has a solution to your issue.

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
irocha
Helper I
Helper I

Hey @ScottShearer , thank you for the response; however, I already have tried that exact approach and it still won't work. Screen Shot 2022-07-12 at 2.45.14 PM.png

@irocha 

You no longer need the loop - try again with no loop and let me know if this works for you.

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Pstork1
Dual Super User
Dual Super User

Are you looking at the url when editing the form?  Or just when filling it in?  The FormID should be in the url when you are editing it.  Also, MS has changed it to just id= rather than FormId=.  And make sure you are using the 'Enter custom value' entry rather than just pasting the formid in.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365 and PWR EduCon in Chicago
EduCon Chicago 2022

irocha
Helper I
Helper I

Screen Shot 2022-07-12 at 3.05.38 PM.png

@ScottShearer I took away the loop and it seems to have gone through! Thank you for that! But the flow still seems to not work. I believe it's not fetching the specific list item response

 

ScottShearer
Super User
Super User

@irocha 

Your screen shot shows that you still have a loop.  Please remove the loop and be sure to select the ID from the trigger when configuring your Get Response Details action.

Your Flow should look something like this:

image.png

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

@ScottShearer thank you so much for all of your help today! You have solved my problem 😄

@Pstork1 thank you for letting me know about the updated FormID being changed to id. This will save me a lot of time searching in the future 👍

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (3,503)