cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Need Help with Flow Error called : ActionBranchingConditionNotSatisfied.

Hi Team, 

 

I am Building a flow to send an email for each item in the SharePoint list when a Condition of field (Temporary Period)  "Expired" Met, 

the Flow runs correctly and i am receiving 2 Emails for 2 Items in the list only then the Flow marked as Successfully while there are more than 10 Items meeting the same condition but the flow didn't send the Email for them. 

 

Kindly assist to check and let me know how to fix this issue. 

 

YeHeart_0-1599938431050.png

 

below is my Flow ,

YeHeart_1-1599938787433.png

 

* below is the Error,

YeHeart_2-1599938941511.png

YeHeart_3-1599939140246.png

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hello Mohammad,

 

So basically you were only getting 2 values because the no. of items returned by your GET ITEMS action were only 100 and only 2 out of those 100 were satisfying the condition.

 

We made the changes so that all your items are returned by the GET ITEMS action, now you will get emails for all those items who satisfy your condition.

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

8 REPLIES 8
Super User II
Super User II

Hello Team,

 

This is not an error, the thing is for rest of the items the Condition does not meet and hence sending of the email is skipped because the Flow moves to the right side of the condition that does not have anything that needs to be done.

 

Can you share a screenshot of your List and the items therein, if the Temporary Period is indeed Expired for all of those items then this flow should surely have sent the emails for all those 10 items.

 

Let me know, awaiting response...

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

 

Hi yashkamdar,

Thanks for your quick response, 

 

Basically, i have calculated column called "Temporary Status " to calculate if the No. Days to expire is less than 0  then to mark the status as "Expired" and if it's between 30 to 1 it will mark the status as "Near to Expired"

the Formula is OK and the Flow is sending only the emails for the below highlighted line Items and ignore the rest!, I tried to remove the flow and create it again but same issue still happening.

 

the Condition in the Flow is to read if the Status is Expired then send Email .

 

below is the screenshot of my list

YeHeart_0-1599941825319.png

 

 

Hello Team,

 

Yeah, that does seem weird but do not worry, we will definitely resolve this.

 

Can you go to the Flow run history and pass across a screenshot of the GET ITEMS action, for some reason i think even though the Condition should satisfy it is still giving the condition expression as False and so this is not resolving.

HI yashkamdar,

 

see below Snapshots 

 

YeHeart_0-1599942519552.png

 

YeHeart_1-1599942584579.png

 

 

Hello YeHeart, 

 

No when I mean the screenshots this is what I want to see highlighted in Yellow, to check how many times the Flow ran and then for one of the iterations where the Condition was FALSE, expand that iteration and show me the inputs as well as outputs therein.

 

yashkamdar_0-1599942913337.png

 

I have also sent you a private message with my Skype ID, we can sort this really quickly over a screenshare if it is okay with you.

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

Hello Mohammad,

 

So basically you were only getting 2 values because the no. of items returned by your GET ITEMS action were only 100 and only 2 out of those 100 were satisfying the condition.

 

We made the changes so that all your items are returned by the GET ITEMS action, now you will get emails for all those items who satisfy your condition.

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Hi yashkamdar,

 

Thanks a lot for your support and assistance, It was a great help.

the issue has been fixed now and i have received all Emails

Hello Team,

 

I am so glad that the issue is now resolved.

 

It was nice working with you, if you have any queries in the future then do post it in the community and if you can help someone with an answer than surely do that, we are here to help each other !!

 

 

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (22,818)