cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JonathanRosales
New Member

New BadGateway error occuring out of the blue.

My flows have been working for about 9 months and on Wed the 21st the flows stopped moving items from point A to point B and started throwing this error instead:

This is using the Outlook365 Move Email (V2) connection. Any thoughts on how to fix this? My local IT team tells me no changes were made to the mailbox settings, and I've tried replacing the connection, the authorization keys, and changing the folders that things were to land in to try and sort this out. What's more odd is other flows using Move Email (V2) work just fine but most of them are broken.

{
"error": {
"code": 502,
"source": "flow-apim-msmanaged-na-westus2-01.azure-apim.net",
"clientRequestId": "68da9dae-d861-489c-ad5c-3fd2be2172d2",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "Mailbox move in progress. Try again later., The user and the mailbox are in different Active Directory sites.\r\nclientRequestId: 68da9dae-d861-489c-ad5c-3fd2be2172d2\r\nserviceRequestId: 1a63f55d-be1f-44ed-bd12-7d8b49c2920f",
"error": {
"message": "Mailbox move in progress. Try again later., The user and the mailbox are in different Active Directory sites.",
"code": "ErrorMailboxMoveInProgress",
"originalMessage": "Mailbox move in progress. Try again later., The user and the mailbox are in different Active Directory sites."
},
"source": "office365-eus2.azconn-eus2-01.p.azurewebsites.net"
}
}
}

{
"Pragma": "no-cache",
"x-ms-datasourceerror": "True",
"x-ms-request-id": "1a63f55d-be1f-44ed-bd12-7d8b49c2920f",
"Strict-Transport-Security": "max-age=31536000; includeSubDomains",
"X-Content-Type-Options": "nosniff",
"X-Frame-Options": "DENY",
"Cache-Control": "no-store, no-cache",
"Set-Cookie": "ARRAffinity=e0b482a211bb8d11992ab083795f48047a477257bf228166fa883d2e1acee181;Path=/;HttpOnly;Secure;Domain=office365-eus2.azconn-eus2-01.p.azurewebsites.net,ARRAffinitySameSite=e0b482a211bb8d11992ab083795f48047a477257bf228166fa883d2e1acee181;Path=/;HttpOnly;SameSite=None;Secure;Domain=office365-eus2.azconn-eus2-01.p.azurewebsites.net",
"Timing-Allow-Origin": "*",
"x-ms-apihub-cached-response": "true",
"Date": "Fri, 23 Apr 2021 16:53:27 GMT",
"Content-Length": "915",
"Content-Type": "application/json",
"Expires": "-1"
}

2 REPLIES 2
jordancrane
Frequent Visitor

We have been getting the same error for over a week now, it is very frustrating and I have spent hours trying to get it to work and have pretty much given up.

Here is our error:
{
  "error": {
    "code"502,
    "source""unitedstates-002.azure-apim.net",
    "clientRequestId""052447af-684b-4823-8781-d3a8a94ac8ea",
    "message""BadGateway",
    "innerError": {
      "status"502,
      "message""Mailbox move in progress. Try again later., The user and the mailbox are in different Active Directory sites.\r\nclientRequestId: 052447af-684b-4823-8781-d3a8a94ac8ea\r\nserviceRequestId: e46ad527-f503-445d-beb2-0e56964b4578",
      "error": {
        "message""Mailbox move in progress. Try again later., The user and the mailbox are in different Active Directory sites.",
        "code""ErrorMailboxMoveInProgress",
        "originalMessage""Mailbox move in progress. Try again later., The user and the mailbox are in different Active Directory sites."
      },
      "source""office365-wus.azconn-wus-01.p.azurewebsites.net"
    }
  }
}
{
  "Pragma""no-cache",
  "x-ms-datasourceerror""True",
  "x-ms-request-id""e46ad527-f503-445d-beb2-0e56964b4578",
  "Strict-Transport-Security""max-age=31536000; includeSubDomains",
  "X-Content-Type-Options""nosniff",
  "X-Frame-Options""DENY",
  "Cache-Control""no-store, no-cache",
  "Set-Cookie""ARRAffinity=fa9050a86380ecce883d8ff2e805dd22d58cc29332b6761a0fc08c7d82b3fa74;Path=/;HttpOnly;Secure;Domain=office365-wus.azconn-wus-01.p.azurewebsites.net,ARRAffinitySameSite=fa9050a86380ecce883d8ff2e805dd22d58cc29332b6761a0fc08c7d82b3fa74;Path=/;HttpOnly;SameSite=None;Secure;Domain=office365-wus.azconn-wus-01.p.azurewebsites.net",
  "Timing-Allow-Origin""*",
  "x-ms-apihub-cached-response""true",
  "Date""Thu, 29 Apr 2021 00:13:06 GMT",
  "Content-Length""896",
  "Content-Type""application/json",
  "Expires""-1"
}

Yup. This solution worked for our needs for about 9 months and it all fell apart this last week. 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (4,116)