cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PhilipCaldwell Advocate I
Advocate I

New Configure Flows option - And my existing Flow is missing!!

I had a flow which was working and the flow has not been changed.  What is different is a new "Configure Flows" option showing up.  I noticed it today and also noticed that the flow selection ( for a "For a selected item" trigger ) was MISSING!!

 

Here is what I see.  Circled above Request sign-off is where my Flow was before.  It is now missing (I've tried both Chrome and IE).  Also, this new Configure flows is there.  I don't know if it is related but it has new options.

 

That said, I tried to create a new flow from scratch just to test this.  I put it to this document library first.  No luck.  I then added it to a List instead on the same site collection - and that worked!  So I've not renamed the document library or changed the security of the site (I'm the owner of the flows and the site collection admin and a global admin also).  I also tried adding it to a different document library on the site.  Also failed.  So then, was this trigger changed (!) to not work on document libraries!!  That would have been nice to know.  That also means I now have production flows that won't be able to be run!

 

image.png

2 ACCEPTED SOLUTIONS

Accepted Solutions
Community Support
Community Support

Re: New Configure Flows option - And my existing Flow is missing!!

Hi @PhilipCaldwell ,

 

It seems that you would like the flow to be triggered when a file is selected in a library.

 

Instead of starting the flow from blank with trigger For a selected item, please try to start the flow from the template Complete a custom action for a selected file. Then set its Site address and Library Name, adding other needed actions.

 

 

About the new Configure flows button, I have made some tests on my side. There are two options “Request sign-off” and “Content approval” if you turn on Do you want approvals in this library.

 

If you select Request sign-off, then Request sign-off select will appear when you select a file.

If you select Content approval, a column Approval Status will be added automatically.

1.PNG

Please take a try with it on your side.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

PhilipCaldwell Advocate I
Advocate I

Re: New Configure Flows option - And my existing Flow is missing!!

I ended up opening a ticket so I could avoid having to re-write everything.  What is below is what the engineer gave as a solution.  That said, I'm actually having a similar issue again today.  However, it is only on the selecting the  ...  next to the list/document item.  Selecting from the page bar is working.  - Probably another MSFT change which is causing a bug.

 

1. For a selected Item trigger  select the enter custom value as highlighted

flow_missing1.jpg

2. Then go to the Library settings and in the URL you will find the ID as highlighted

flow_missing2.jpg

 

Now give the highlighted party in the list name so that the flow will be reflected in the SharePoint see picture 3

flow_missing3.jpg.png

 

Picture 3

flow_missing4.jpg

View solution in original post

8 REPLIES 8
Super User
Super User

Re: New Configure Flows option - And my existing Flow is missing!!

I'd suggest not triggering the Flow from SharePoint, I'd instead visit https://flow.microsoft.com and create your Flow in the My flows area. 

The Excel connectors were changed about a year ago, and the Excel connector is being deprecated, so you should be using the new Excel Online (Business) or the Excel Online (OneDrive) connetors. 

If you could provide an expanded screenshot of your Flow and steps, and of any detailed error messages you're receiving we could likely better assist you.

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

PhilipCaldwell Advocate I
Advocate I

Re: New Configure Flows option - And my existing Flow is missing!!

I created the flow in the My Flows area.  The flow does not use an Excel connector.  It is triggering on a document in a document library in SharePoint.  The document could be a pdf or a picture for all the flow cares.  The user is deciding on when the document is ready to be processed using the flow.  The flow was working just fine.  The issue is that the selection to trigger the flow is no longer there where it was just a few days ago.  For list items (not a document library) it is still there.  So the issue is that they changed something about document libraries.

Super User
Super User

Re: New Configure Flows option - And my existing Flow is missing!!

Again, without expanded screenshots of your entire Flow, we can't really help you.

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

PhilipCaldwell Advocate I
Advocate I

Re: New Configure Flows option - And my existing Flow is missing!!

The point is that the flow is not showing up as selectable on the document.  Showing the actual entire flow is not really necessary.  Here is the trigger.  This flow has not changed in over a month and was working.  What has changed is how SharePoint is displaying ( or not in this case) what flows are available to run on a document library.image.png

Community Support
Community Support

Re: New Configure Flows option - And my existing Flow is missing!!

Hi @PhilipCaldwell ,

 

It seems that you would like the flow to be triggered when a file is selected in a library.

 

Instead of starting the flow from blank with trigger For a selected item, please try to start the flow from the template Complete a custom action for a selected file. Then set its Site address and Library Name, adding other needed actions.

 

 

About the new Configure flows button, I have made some tests on my side. There are two options “Request sign-off” and “Content approval” if you turn on Do you want approvals in this library.

 

If you select Request sign-off, then Request sign-off select will appear when you select a file.

If you select Content approval, a column Approval Status will be added automatically.

1.PNG

Please take a try with it on your side.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

PhilipCaldwell Advocate I
Advocate I

Re: New Configure Flows option - And my existing Flow is missing!!

@v-yamao-msft  using the For a selected file trigger does seem to work and it does show up on the Flow dropdown in the document library item.  That said, the fact that Flows triggered using the For a selected item trigger, which in just the last few days was working, but now is no longer working, is quite troubling.  This being the case, I will have to REWRITE all effected flows.  If this was an intended change, where was the communication about it please!?  If it was a side-effect of another change, back the change out and re-work it.  Some of my flows go to high-level people in my company.  I have no problem blaming Microsoft for the issue.  I still have to provide a work-around for them.

 

Here is it showing the test using the other trigger type working.

 

for_selected_file_trigger_working.png

annemie
Frequent Visitor

Re: New Configure Flows option - And my existing Flow is missing!!

Same problem here, it was working just fine yesterday and now the option to select the flow has disappeared... any solutions ?

PhilipCaldwell Advocate I
Advocate I

Re: New Configure Flows option - And my existing Flow is missing!!

I ended up opening a ticket so I could avoid having to re-write everything.  What is below is what the engineer gave as a solution.  That said, I'm actually having a similar issue again today.  However, it is only on the selecting the  ...  next to the list/document item.  Selecting from the page bar is working.  - Probably another MSFT change which is causing a bug.

 

1. For a selected Item trigger  select the enter custom value as highlighted

flow_missing1.jpg

2. Then go to the Library settings and in the URL you will find the ID as highlighted

flow_missing2.jpg

 

Now give the highlighted party in the list name so that the flow will be reflected in the SharePoint see picture 3

flow_missing3.jpg.png

 

Picture 3

flow_missing4.jpg

View solution in original post

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Users online (9,847)