cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
RM
Level: Powered On

No Dynamic Content when using 'HTTP request' to 'Get Item' on Sharepoint List

Hi,

 

I'll start by inserting a picture as that will show this problem very clearly.

 

lala.png

 

As you can see, I want to be able to post some JSON containing a singular value (id) to a URL, and have it get an item from a SharePoint list. However, there is no dynamic content available.

 

What's odd is that if I change 'Get Item' to 'Get Items' and expand the advanced options pane, it can see the 'id' being passed via the JSON object:

 

lala2.png

 

 

 

However, I don't want to get all items, I just want to get 1 item.

 

I tried using 'Get Items' and trying to filter, using: id eq id (where the second was the dynamic content) but the flow failed and said 'The expression \"id eq\" is not valid.' as though no value is being received.

 

Ideally, I would just use 'Get Item' and not 'Get Items'.

 

Any ideas?

 

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
RM
Level: Powered On

Re: No Dynamic Data when using 'HTTP request' to 'Get Items' on Sharepoint List

Solution:

 

Change the JSON schema from 'number' to 'integer' and then dynamic content is available in the 'id' box for a SharePoint list item.

View solution in original post

3 REPLIES 3
RM
Level: Powered On

Re: No Dynamic Data when using 'HTTP request' to 'Get Items' on Sharepoint List

Further to this, the flow will work if I manually enter an id value but obviously this isn't dynamic and therefore, not what I want.

RM
Level: Powered On

Re: No Dynamic Data when using 'HTTP request' to 'Get Items' on Sharepoint List

There are definitely some odd glitches with Flow.

 

if I click into the 'List Name' box and choose 'Enter custom value', sometimes the dynamic content will appear for a split second before vanishing and saying 'No dynamic content available'. If I keep switching between selecting the only list in the SharePoint group, and 'Enter custom value' then sometimes the dynamic content options stick and I can select them as shown:

 

lala3.png

 

However, nothing seems to work in getting the dynamic content to display in the 'id' box Smiley Frustrated

RM
Level: Powered On

Re: No Dynamic Data when using 'HTTP request' to 'Get Items' on Sharepoint List

Solution:

 

Change the JSON schema from 'number' to 'integer' and then dynamic content is available in the 'id' box for a SharePoint list item.

View solution in original post

Helpful resources

Announcements
firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,101)