cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
johnjohn123
Super User
Super User

No Dynamic content when trying to get the document id

I have a flow which runs when create or modify a document:-

 

johnjohn123_0-1660763585166.png

 

 

but when i tried to get the document Id, inside "set content approval status", i got "no dynamic content", as follow:-

 

johnjohn123_1-1660763637441.png

 

any advice?

 

 

13 REPLIES 13
StretchFredrik
Super User
Super User

Hello, what if you take a step to get the metadata of the item? Do you get any dynamic data then?

johnjohn123
Super User
Super User

@StretchFredrik  thanks .. this is a file and not a item.. and when i try to get the file properties i am unable to select the file ID .. the id that comes from the first action "when a file is created or modified in a folder" will not work.. 

 

 

 

The 'inputs.parameters' of workflow operation 'Set_content_approval_status_=_Rejected' of type 'OpenApiConnection' is not valid. Error details: Input parameter 'id' is required to be of type 'Integer/int64'. The runtime value '"%252fIOErrorEventandIncidentReportingTest%252f22222222222222222222.docx"' to be converted doesn't have the expected format 'Integer/int64'.

 

StretchFredrik
Super User
Super User

I see, can you try pasting this in? @{triggerOutputs()?['body/ID']} maybe that will work. 

johnjohn123
Super User
Super User

@StretchFredrik  using `@{triggerOutputs()?['body/ID']}` will raise this error:-

 

The 'inputs.parameters' of workflow operation 'Set_content_approval_status' of type 'OpenApiConnection' is not valid. Error details: The resolved string values for the following parameters are invalid, they may not be null or empty: 'id'

 

StretchFredrik
Super User
Super User

Weird,

 

Could you try and re-authenticate the trigger step with a new connection?

johnjohn123
Super User
Super User

@StretchFredrik  tried on my test tenant, and same problem.. is it working at your end?

 

 

StretchFredrik
Super User
Super User

Yeah no issues here, maybe the region your tenant is in has some downtime right now. 

 

johnjohn123
Super User
Super User

@StretchFredrik  i tried on a tenant in canada and tried on a tenant in UAE .. same issue

StretchFredrik
Super User
Super User

Weird, my tenant is EU and works fine. 

johnjohn123
Super User
Super User

@StretchFredrik  could be that we did not understand the issue, can you post a screen shot how you are getting the document id inside the "set approval status " action for a document ?Thanks

StretchFredrik
Super User
Super User

Sorry for the steps being in swedish, first step is triggered when a item is created or changed, and then its the standard content approval thingy.

 

StretchFredrik_0-1660766370901.png

 

johnjohn123
Super User
Super User

@StretchFredrik  so you are trying this on a list and item and not on document and document library (as in my case)?

StretchFredrik
Super User
Super User

Ive tried both objects and files, and they both work. 

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (1,545)