cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Andreas_Behrens
Regular Visitor

No dynamic content available from Sharepoint list

I'm working on a flow, where i want to add some of the fields from a sharepointlist.

However it seems that Flow doesn't make the fields available anymore. It says that no dynamic content is available.

 

Flow no dynamic content.PNG

 

Any explanation/solution to this problem?

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Mabel

 

The problem seems to resolved, as I can now access the dynamic content when creating a new flow.

The old flow still doesn't have acces to the dynamic content but those i'll just recreate from scratch.

 

Whatever you did worked 🙂

 

Thanks for the assitance.

Best regards

 

Andreas Behrens

 

View solution in original post

14 REPLIES 14
v-yamao-msft
Community Support
Community Support

Hi Andreas_Behrens,

 

It seems that you have already selected many outputs from the Dynamic content. How is your flow configured? Could you show me a whole screenshot of your flow?

 

Please try to click on the blank of the box or re-click the Add dynamic content button, I guess this should show the dynamic content.

dynamic content.PNG

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I've tried clicking where you indicated, but no luck.

My flow looks like this "When a new item is created" --> "Send an email"  (I can't paste the picture).

 

Also, if I make a new flow, in the same or in a different list, dynamic content still doesn't appear.

Oh, now i can paste the screenshot of my flow.

 

Flow1.PNG

Hi Andreas_Behrens,

 

Thanks for your reply. Could you tell me your location? Could you get the List after you enter the Site url? Could you try to sign in again to see if you would still get this error?

 

I tried again on my side by creating a similar flow with you. But I can select all the Outputs from the trigger “When a new item is created in SharePoint” in the Body field. Below is the screenshot of my flow:

dynamic content.PNG

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel

 

My location is Denmark.

I've tried logging out and in again - no change

Reentering the site url doesn't cause the dynamic content to appear.

 

 

Hi Andreas_Behrens,

 

Could you show me your Flow name and flow id? Flow id should be the set of alphabet / numbers in the url after the last slash when you open the flow in edit mode.

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel

 

My Flowname is "Besked til trykkeriet ved ny bestilling", see below.

My flow ID should be: b41d943c-9e3b-44e2-947a-021b33d6141c

 

flowname.PNG

Hi Andreas_Behrens,

 

Are you still having this issue on your side? If yes, could you try to delete your SharePoint connection and add a new one to see if this works for you?

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel

 

The problem seems to resolved, as I can now access the dynamic content when creating a new flow.

The old flow still doesn't have acces to the dynamic content but those i'll just recreate from scratch.

 

Whatever you did worked 🙂

 

Thanks for the assitance.

Best regards

 

Andreas Behrens

 

View solution in original post

Hi Andreas_Behrens,

 

Thanks for your feedback. I am glad to here that it working now.

Please feel free to post your issues here, we are always ready to help.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Everyone,

 

I am facing an issue while creating a MS Flow, not sure why the Dynamic content is not shown for one Sharepoint list whereas it shows for other lists on the same site. I have tried recreating the list as well as the flow but no luck.

Any help here would be greatly appreciated.

I've discovered what i think is a bug in Flow.

 

If you create a multi choice field in a sharepoint list (i used Infopath Designer 2013) and make it mandatory, the dynamic content wont be available when making a flow on that list.

 

So if you have mandatory multi choice field, make them non-mandatory.

 

I hope that helps.

 

Best regards

 

Andreas Behrens

Hi Andreas,

 

Thanks for the reply, i have noticed its because of the multi choice field but wasnt sure that we can use a non mandatory multi choice field.

Thanks, that helps:)

@Andreas_Behrens She didn't do anything she just kept you distracted until the issue randomly fixed itself like it always plays out with Flow (or I'm sorry, should I say "Power Automate")

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Users online (20,971)