cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

No dynamic content option

I am trying to initialize a variable. In examples I see there is an option for dynamic content, but I seen no such link, and my expressions end up being text.

 

I've attached what it looks like for me, the compose and initialize variable steps.

Also attached is what i see in examples. A link to add dynamic content. How do I enable this so i can paste in an expression.

 

Thanks.

 

What I see:

 

Compose.pngInitialize.png

 

What I see in examples:

example.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Regular Visitor

Re: No dynamic content option

I have tried this on a different computer and it's now working as expected. Perhaps there was a browser issue.

View solution in original post

15 REPLIES 15
Highlighted
Regular Visitor

Re: No dynamic content option

I have tried this on a different computer and it's now working as expected. Perhaps there was a browser issue.

View solution in original post

Highlighted
Advocate II
Advocate II

Re: No dynamic content option

I am facing the same issue. It is not working in any browser. I don't have option to use another computer as I will eventually need it working on my laptop for further development.

Highlighted
Advocate II
Advocate II

Re: No dynamic content option

Correction! I can see the Add Dynamic Content on another PC and was able to use it. However, I need it working on my primary laptop. Why is it hidden? Bug?

Highlighted
Frequent Visitor

Re: No dynamic content option

I am also having this exact problem.


@YatinMumbai wrote:

Correction! I can see the Add Dynamic Content on another PC and was able to use it. However, I need it working on my primary laptop. Why is it hidden? Bug?


 

Highlighted
Helper II
Helper II

Re: No dynamic content option

I have the same problem. get file properties.PNG

Highlighted
Frequent Visitor

Re: No dynamic content option

It's the video resolution on your computer.  I found that there are apparently two 'modes' for displaying that content and it depends on the vid resolution which one you get.  Actually sometimes there are things that show  up in the mode for low res (1280x720 in my case) that don't show up in the bigger view (1600x900).  I sometimes switch between them so in my case anyway it's the screen resolution that's the magic factor.

 

Highlighted
Helper II
Helper II

Re: No dynamic content option

Hi Rob,

 

I have tried to change the resolution and is still not working 😞 .

Highlighted
Frequent Visitor

Re: No dynamic content option

Wow.  That was definitely my answer.  I can replicate the problem perfectly with video resolution changes and switch between the two modes very easily.  Is there anything special about your setup?  Increased font sizes? Any adaptive tech for visual imparement? Browser set to shrink or magnify?  Maybe try a browser with a different setup.  I find I have to use Chrome to get good performance when programming Flows.

Highlighted
Helper II
Helper II

Re: No dynamic content option

I never had this issue. Yesterday I created a flow and I had no problems with this.

Highlighted
Frequent Visitor

Re: No dynamic content option

Does it work on a different machine and/or browser?  Most people reported it working on some computers and not others which is how I wound up finding the resolution thing.  I don't know the exact resolution that changes it for me, but I switch between 1280x720 and 1600x900 and it works every single time.  It's the only factor I've found that fixes it for me.  😞

Highlighted
Helper II
Helper II

Re: No dynamic content option

I have tried on Internet Explorer and on Edge. I don't know if this issue reproduce on another computer.

But it is very strange that I didn't have this issue until today.

Highlighted
Frequent Visitor

Re: No dynamic content option

I agree.  It's strange.  I use Chrome for mine.  I don't know if that will help.  I think I'm out of ideas otherwise.

Highlighted
Helper II
Helper II

Re: No dynamic content option

Thank you for your kind support!

I will try Monday morning again, maybe it will be better.

Highlighted
Advocate II
Advocate II

Re: No dynamic content option

IT WORKS! Changing resolution worked! In fact, first I changed the resolution to a larger one (2560x1600), and then I changed it back to recommended resoltuion (2736x1824), it still works. 

The Problem is TEXT SIZE: I had set the font text size at 250% (Scale and Layout option in Display Settings). When I changed to 225% it works and I see Dynamic Content link. At 250% it does not show the link. 

Hope this helps others. Thanks to @Rob_Whelan for the tip.

Highlighted
Frequent Visitor

Re: No dynamic content option

The text size thing makes sense too.  I think it's got to be some percentage of screen space that has to be available  before Flow will show that dynamic content full menu thing.  I'm glad your problem is resolved.

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,343)