cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Saurabh-704
Helper III
Helper III

Not able to import excel data into Sharepoint list

I am creating a flow to import excel data to sharepoint list but what is happening like flow is running fine but data is not getting copied into the sharepoint.

I am attaching screenshot also for your reference.

excelsp2.pngexcelsp1.pngexcelsp3.png

 

As you can see flow ran successfully. But strange thing is that I am not able to see details for "Apply to each step" .

excelsp4.png

 

So please can anyone help me like where I am lagging ? 

Thanks in Advance!!

2 ACCEPTED SOLUTIONS

Accepted Solutions
RobElliott
Super User
Super User

@Saurabh-704 have you made sure you've got test data in your Excel spreadsheet? Or have you added a a filter query to the List rows action? If the table is empty or if the filter query returns nothing then there is nothing the for the Create item to work with so nothing will be created.

 

Rob
Los Gallardos
If I've answered your question or solved your problem, please mark this question as answered. This helps others who have the same question find a solution quickly via the forum search. If you liked my response, please consider giving it a thumbs up. Thanks.

View solution in original post

v-litu-msft
Community Support
Community Support

Hi @Saurabh-704,

 

Have you confirmed the content of the Excel table?


If your problem has been solved, You could go ahead and mark the post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

Best Regards,
Community Support Team _ Lin Tu

View solution in original post

3 REPLIES 3
RobElliott
Super User
Super User

@Saurabh-704 have you made sure you've got test data in your Excel spreadsheet? Or have you added a a filter query to the List rows action? If the table is empty or if the filter query returns nothing then there is nothing the for the Create item to work with so nothing will be created.

 

Rob
Los Gallardos
If I've answered your question or solved your problem, please mark this question as answered. This helps others who have the same question find a solution quickly via the forum search. If you liked my response, please consider giving it a thumbs up. Thanks.

View solution in original post

v-litu-msft
Community Support
Community Support

Hi @Saurabh-704,

 

Have you confirmed the content of the Excel table?


If your problem has been solved, You could go ahead and mark the post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

Best Regards,
Community Support Team _ Lin Tu

View solution in original post

Thank you @RobElliott and @v-litu-msft for your response and time. Actually what happened I only formatted header and second row as Table format. But rest of thing was not in table format. So because of that  flow was not able to read all the contents. 

But as you both asked to check one time so because of that I was able to understand where problem might be and after some time I came to know about that format issue. 

So it got resolved after that. So thank you for your time.

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (55,667)