cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Community Champion
Community Champion

ONEDRIVE FOR BUSINESS BUG: 502 Bad Gateway

Scenario:

  • Trigger: When a .zip file is created in a OneDrive folder
  • Action1: Extract archive to folder
  • 6 days ago, this Flow succeeded
  • Now, Flow fails with a 502 Bad Gateway
  • 17/18 of the files are successfully extracted, 1 file (a .jpg nested in a subfolder) is the problem
  • When I remove this .jpg, the Flow is successful
  • The .jpg is not the same with each Flow. Its name/size/etc changes with each .zip folder in the Flow.

Trigger output:

{
    "statusCode": 200,
    "headers": {
        "Pragma": "no-cache",
        "Retry-After": "15",
        "x-ms-file-id": "<longString>",
        "x-ms-file-name": "test-1.zip",
        "x-ms-file-name-encoded": "<longString>",
        "x-ms-file-path": "/drives/<longString>/root:/test/test-1.zip",
        "x-ms-file-path-encoded": "<longString>",
        "x-ms-file-etag": "\"{<longString>},2\"",
        "x-ms-request-id": "<longString>",
        "Timing-Allow-Origin": "*",
        "x-ms-apihub-cached-response": "true",
        "Cache-Control": "no-cache",
        "Date": "Fri, 13 Sep 2019 18:37:21 GMT",
        "Location": "https://flow-apim-msmanaged-na-northcentralus-01.azure-apim.net/apim/onedriveforbusiness/shared-onedriveforbu-<longString>/datasets/default/triggers/onnewfile?folderId=<longString>&inferContentType=True&ts=<longString>",
        "X-AspNet-Version": "4.0.30319",
        "X-Powered-By": "ASP.NET",
        "Content-Length": "435889",
        "Content-Disposition": "attachment; filename=\"test-1.zip\"",
        "Content-Type": "application/x-zip-compressed",
        "Expires": "-1"
    },
    "body": {
        "$content-type": "application/x-zip-compressed",
        "$content": "<huge string here>"
    }
}

Error message: 

{
  "error": {
    "code": 502,
    "source": "flow-apim-msmanaged-na-northcentralus-01.azure-apim.net",
    "clientRequestId": "fa6d5-f33-49-9a75-4c6878",
    "message": "BadGateway",
    "innerError": {
      "status": 502,
      "message": "Unable to upload contents of file '/drives/b!sqRVGexbFLMVEqpMndFN7QROuG9hdy4/root:/test/test-1.zip': One or more files failed to upload.",
      "source": "api.connectorp.svc.ms"
    }
  }
}

image.png

I need help on this bug. Anyone have ideas?

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @ericonline  ,

 

Does your problem still exists?

If the error code 500 or 502 appears, the failure is temporary or transient.

Please click or tap Resubmit to try the flow again and let me know if the issue still exists.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
Community Support
Community Support

Hi @ericonline  ,

 

Does your problem still exists?

If the error code 500 or 502 appears, the failure is temporary or transient.

Please click or tap Resubmit to try the flow again and let me know if the issue still exists.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi @v-alzhan-msft , Thank you for the follow up. I just tried the Flow again and it worked without issue. Some additional questions for you/Microsoft:

1. What are some strategies for handling 502 errors for business critical Flows?

2. What are some strategies for rerunning Flows after the service becomes available again?

3. Is Microsoft looking into this issue?

Thanks again!

Hi @ericonline ,

 

I'm afraid that the issue is caused by microsoft and it issue has fixed now.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

I am having the exact same issue when trying to extract a zip file to OneDrive for Business folders.  I have had no successful flow runs.  Same 502 Bad Gateway error each time.  This has been ongoing for about 10 days now.

Frequent Visitor

@47Minutes 

I'm having the same issue when extracting a zip file. Has there been a solution to this?

I'm having the same issue when extracting a zip file. Has there been a solution to this?

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (76,619)