cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Obtain URL of Flow with Request Trigger

Hi, within my solution I have FlowX which acts as a webservice to return data from the CDS, and another FlowY which generates URLs pointing to FlowX with unique parameters. After deploying the solution to another Environment how can FlowY determine the new URL for FlowX? Appreciate the help.

8 REPLIES 8
abm
Super User
Super User

Hi @Anonymous 

 

Could you reconfigure the new URL?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
Anonymous
Not applicable

Yes of course I can do it manually but I'm looking for an automated method to make it easier to deploy to client environments

Hi @Anonymous 

 

So when you change the URL manually after the deployment is it same as your dev or UAT environment?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
Anonymous
Not applicable

hmm well I've just tried the manual method now and it seems like it won't even generate a URL after deploying as part of a solution. I have already saved it, and tried saving multiple times after.

 

 2020-03-12_11-24-05.png

Hi @Anonymous 

 

I can't see any schema here? My understanding is this must be a unique URL between environments. If you have same URL for all environments it doesn't make sense which one to invoke for? This behaviour must be by design.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
Anonymous
Not applicable

well yes that's exactly right; and I was expecting that it would generate this unique URL after deployment, but it's not?

 

also I don't have a schema because its a GET request

Hi @Anonymous 

 

Thanks for your quick reply.

 

It won't generate it automatically. Currently the only option is after deployment manually edit and save the flow. You could add this an idea for the future release.

 

https://powerusers.microsoft.com/t5/Power-Automate-Ideas/idb-p/MPAIdeas

 

Thanks

 

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
Anonymous
Not applicable

OK, but actually even after edit and save it's not generating

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (1,827)