cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

On Premises Data Gateway - Cannot find file path

Hi All,

 

I am pulling my hair with trying to get an on premisis data gateway setup for saving files from Sharepoint to a local server.

 

I have the connection setup correctly as I am able to navigate through the folder structure in Flow to select the folder I want to save to or get information from. However, when I run the flow it fails because it is not able to find the filepath

When I check the failed flow this it what it shows me:

{
"status": 400,
"message": "The requested action could not be completed. Check your request parameters to make sure the path '\\\\NAS3\\Test' exists on your file system.\r\nclientRequestId: c6f6b2dd-c4a4-4ce4-80b6-192bd4424dd9",
"source": "filesystem-eus.azconn-eus.p.azurewebsites.net"
}
 
Should the filepath have double backslashes??...
NAS3 is the name of the mounted volume that im wanting it access but also show the same if I try it pointing at the C drive of that machine.
Any pointers would be great - Ive seen alot of other posts but their issues relate to the user authentication which I know mine is fine as I can see the folder structure in Flow
 
Many Thanks

 

6 REPLIES 6
Harry_G
Level 10

Re: On Premises Data Gateway - Cannot find file path

hi, 

There is Two scenario if you want to add path in your local machine than give path in this way 

1.JPG

For user name if you are a user of any domain add user name with domain\Username

Secondly if your want to make gateway in network folder follow this step.

2.JPG

 

Starts with double slashes like \\rootfolder\folder\file . 

If you find this helpful, Please mark it as solution.

Thanks,

Harry_G

Anonymous
Not applicable

Re: On Premises Data Gateway - Cannot find file path

Hi @Harry_G and thanks for the quick response.

 

The connection type is domain based as its a machine at the office.

This part of the process I already having working etc as im able to navigate the folder structure inside by root folder on MS Flow:

 

Screen Shot 2019-02-14 at 2.53.22 pm.png

So I know theres nothing wrong with the connection as I can see the folders etc and when ive tried other methods with the connection that doesnt work it wont let me navigate

 

The issue is when I try to run it:

Screen Shot 2019-02-14 at 2.55.32 pm.png

 

The error is:

{
"status": 400,
"message": "The requested action could not be completed. Check your request parameters to make sure the path 'C:\\Users\\administrator/test.doc' exists on your file system.\r\nclientRequestId: df8103fb-bf28-4e64-b5f2-f405b49ab3b9",
"source": "filesystem-eus.azconn-eus.p.azurewebsites.net"
}
 
Many Thanks
Harry_G
Level 10

Re: On Premises Data Gateway - Cannot find file path

hi @Anonymous,

Please check test.doc is already exist in that folder and not? This is occured when file is opened already because data is not write in file when file is opened. If file is not opened please try this formula Base64('content') or see below pic.

 

Capture.PNG

 

If this solve your problem , Please Accept it as a solution.

 

Thanks,

Harry_G

Super User
Super User

Re: On Premises Data Gateway - Cannot find file path

@Anonymous , what was your final solution here. This one always gets me too. 

Here are some of the factors that cause issues with Create File & On-prem gateway:

  • Double slashes at the beginning of the network path
  • Final slash on the end of the network path
  • DOMAIN\username in the Username field. Most people put the WRONG slash. Notice the direction.
  • Ensure permissions are set correctly

I've also seen the connection "just take time" to get established. AKA: Didn't change anything, just started working after a given time. 

Hope this helps others!

houmanmohebbi
Level: Power Up

Re: On Premises Data Gateway - Cannot find file path

I recieve the same error when trying to create a file using the filesystem connector in Logic Apps. This error started occuring suddenly, without any changes to the workflow. And now it seems to be permanent. 
 
Anyone found a solution to this or maybe a workaround?
 
{
"status": 400,
"message": "The requested action could not be completed. Check your request parameters to make sure the path '' exists on your file system.\r\nclientRequestId: ,
"error": {
"message": "The requested action could not be completed. Check your request parameters to make sure the path '' exists on your file system."
},
"source": "filesystem-we.azconn-we-01.p.azurewebsites.net"
}
Harry_G
Level 10

Re: On Premises Data Gateway - Cannot find file path

@houmanmohebbi  can you please share screen shots where your connection build with on-premises gateway?

 

regards,

Harry_G

Helpful resources

Announcements
firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors
Users online (4,597)