cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Only one row showing

Hi all,

 

I've got this bit of the process that pull the content of an excel file created earlier in the flow, it should contain 2 rows I've opened the file directly and it shows 2 rows. However the delivered attachment on the sent email only contains the 1st row not both.

Annotation 2020-05-28 120421.jpg

Anyone got any ideas where this could be going wrong?

 

Thanks

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Super User II
Super User II

@Deano12  I see your flow perfect what I suggest you is add a deley action with 5 seconds before file content reading to give the flow the change to write the rows.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

View solution in original post

Community Support
Community Support

Hi @Deano12,

 

Before the Get file content action, what you did is add a row into Excel table and get the updated Excel file to sent in Email?

If so, I think the issue of the reason is the Get file content not get the content of the updated file, cause there is no time to sync the content after the file update, and the file content is the previous version.

As a workaround, just like @ChristianAbata said, add a delay action before the Get file content action, or you could let the delay time longer, it's safer for one minute if you're not in a hurry.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Super User II
Super User II

@Deano12  I see your flow perfect what I suggest you is add a deley action with 5 seconds before file content reading to give the flow the change to write the rows.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

View solution in original post

Community Support
Community Support

Hi @Deano12,

 

Before the Get file content action, what you did is add a row into Excel table and get the updated Excel file to sent in Email?

If so, I think the issue of the reason is the Get file content not get the content of the updated file, cause there is no time to sync the content after the file update, and the file content is the previous version.

As a workaround, just like @ChristianAbata said, add a delay action before the Get file content action, or you could let the delay time longer, it's safer for one minute if you're not in a hurry.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helper I
Helper I

Thank you both.

 

It's working after the delay add.

 

However I had to set the delay time to 1 minute before it would pick up the changes. At least it works.

 

Thanks all.

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (9,504)