cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Outlook 365 Trigger not working

Hello, I created Flow with trigger: "On new Email with Attachement",
Problem is that trigger is not working , or is working only sometimes.
I have tested it m any times with the same parameters.
Condition in trigger is set to "Filter subject":"

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi @PowerEmil 

 

Perfect!

 

Yes I am using that trigger in my production environment flows and it just works fine. You can try enabling concurrency on your flow as I think that the emails are not triggering because either it is too frequent or the flow is taking too long to execute the previous runs. You can create a test flow for this and check out by changing the settings on the trigger. To change the settings, click the ... on the trigger and click on settings and enable concurrent as shown in the image below:uee.png

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

I set the properties of the trigger:

 

Flow problem2.png

but sorry - trigger still not starting

View solution in original post

12 REPLIES 12
Dual Super User II
Dual Super User II

Hi @PowerEmil 

 

Can you elaborate on the errors that you are getting? Can you please post a screenshot of the flow? That way we might be able to assist you better!

Frequent Visitor

Hi @yashag2255 thank you for response

problem is that flow is not triggered at all, (No errors ...)

Sorry abou language (I am in Slovakia). Flow Ootlook 365 Trigger : "On new Email with Attachement"

Little beat of translation:

"Priecinok" : Folder (Incomming post)

"Komu": To

"Filter Predmetu": Filter of Subject: "NMB"

Flow problem.png

Hi @PowerEmil No Problem!

 

Please check these things: 

1. Do you have a rule set in outlook that an email arrives in that inbox? or are you manually moving the email from some other folder to that folder? If you are manually moving, it will not work at all. 

2. You should make the Has Attachments and INclude Attachments to Yes. 

 

For now, can you try running the flow by changing the folder to Inbox and see if the email arrives in inbox the flow triggers or not?

 

Thanks 

1. Yes I have a rule in outlook / works fine

2. include atachements set up to Yes

3, Folder in the flow set up to Inbox

 

Testing ... the same Issue

 

I changed Outlookand  parameters in Flow:

- Deleted rule in Outlook

Flow:

- No Inbox (empty)

- To - the same adress

- Subject Filter: " NMB"

Tested few times, first time - trigger started OK, second and next - trigger not started {only one time started )

 

btw: have you ever used this trigger in your Flows?

 

Hi @PowerEmil 

 

Perfect!

 

Yes I am using that trigger in my production environment flows and it just works fine. You can try enabling concurrency on your flow as I think that the emails are not triggering because either it is too frequent or the flow is taking too long to execute the previous runs. You can create a test flow for this and check out by changing the settings on the trigger. To change the settings, click the ... on the trigger and click on settings and enable concurrent as shown in the image below:uee.png

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

I set the properties of the trigger:

 

Flow problem2.png

but sorry - trigger still not starting

View solution in original post

Hi @yashag2255 

what is interesting ? - that trigger is strating (and finish) only one time (first email), each other emails sent immediately after the first one does 'nt activate the flow (trigger not started)

@PowerEmil There is some blocker that is failing the flow from triggering. Can you log out of the current session-> close window -> open a fresh window and login and check this one more time? Is the email that arrives directly to the folder and how much is the time difference between any two emails?

@yashag2255 GOOD NEWS

 

maybe after parameters changing it needs some more time, now all email are working:)

intervals between triggers are at about 20 seconds, but are working , I will test it more an I will let you know about result, thanks you so much

Perfect!

 

So it is not recognising all the emails that are coming in at the same time frame and picking the newest one. Along with the concurrency control you should add the delay as you mentioned in the post. 

 

Glad that it worked!

 

If my reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi @yashag2255 

trigger still working 

 

Thank You very much

Have nice day

Do you have other suggestions?  My trigger worked once and has not worked since unless i rerun a test on a previous run.  I believe i have set it up the way you suggested.  I have no rules set up.  I want it to trigger when an email hits the inbox.

 

image.png

 

 

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (2,060)