cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Outlook Contact unable to create contact from Typeform.

I have a simple flow where, when a Typeform is filled out, the contact information is added to Outlook Contacts. I keep running into an error where "it seems" something regarding the Contact ID is failing. What's odd is that some typeforms are working and some are not. Not being a programmer, I have no clue what is causing the error. Where can I find documentation on how to resolve this issue?

 

Here's a sample of the error message:

EmailAddress or ItemId must be included in the request.
clientRequestId: 4be27629-e073-4032-ba98-20d1975a72cd
serviceRequestId: f52da22d-05d4-4f61-848c-15855a4c3c5b

1 ACCEPTED SOLUTION

Accepted Solutions

@JosephTI was able to duplicate the issue. 

 

You will need to click on the icon next to the email field and remove any of the additional text that is not the dynamic contect email field.  After those changes it should work for you.

 

contact.jpg

 

If this is helpful please mark as a solution.

View solution in original post

10 REPLIES 10
Helper V
Helper V

@JosephTdo you have a screenshot you can include to help me uderstand what exactly your are trying to do in Flow?

Flow.png

Do those values show in the trigger? When the flow runs and you expand the "When a response is submitted" do you see the email and id values?

Instead of "email" it is "16: e-mail address" (the number being the line in the form).

I didn't create an ID in Typeform and wouldn't know what Outlook would want in an ID.

If you remove the email address does it work?   I am trying to duplicate your issue but I can't get my Typeform to connect.  I only have access to the free version right now so I am not sure if that is why I can't connect.   The next steps that I would take is to put the email in a variable or just send a test email to yourself in the Flow and put the email address in the body.   If they output is not an email address format then I would say there is an  issue with Typform.

I'm a free user as well. Can you direct me on how to set the email as a variable and (hopefully) make this work? I would like to learn how this is done.

Community Support
Community Support

Hi @JosephT,

 

You didn't fill in a value in the "Email addresses Address" column of Create contact action so the flow run failed with the error message that you mentioned.

 

Please make sure to fill in a email address in the "Email addresses Address" column of Create contact action.

Capture.PNG 

 

 

Best regards,

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

There was something in there prior, but I added it again and the tested flow failed for the same reasons.

@JosephTI was able to duplicate the issue. 

 

You will need to click on the icon next to the email field and remove any of the additional text that is not the dynamic contect email field.  After those changes it should work for you.

 

contact.jpg

 

If this is helpful please mark as a solution.

View solution in original post

Hallelujah! Thank you SO much!

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (6,874)