cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Driede
Level: Powered On

Output in For a selected item disappears after saving flow

I have an approval flow that is based on the "Request manager approval for a selected item" template. That flow has an output named "Message" and the flow works without problems.

 

I wanted to build another flow using the same "For a selected item" trigger as the template but whenever I try to add another output (with "Add an output") to the trigger, although it adds the output and allows me to save the flow when I close the flow and open it again the output is gone.

 

I haven't been able to keep any of the outputs I add.

14 REPLIES 14
LMA
Level: Powered On

Re: Output in For a selected item disappears after saving flow

I have the same problem. It worked fine two weeks ago

Community Support Team
Community Support Team

Re: Output in For a selected item disappears after saving flow

Hi @ Driede,

 

Could you please share a screenshot of the configuration of your flow?

Does your problem still exists?

I have made a test on m side and don't have the issue that you mentioned.

 

Please share more details so we could try to help you.

 

Regards,
Alice Zhang

LMA
Level: Powered On

Re: Output in For a selected item disappears after saving flow

It is basically very simple: I make a simple flow (just one step) on any list or library. I use one text output field to capture input from the user. I save the flow and test. The Output field is NOT displayed when I run the flow. When I open the flow in edit mode again the output field has disappeared. I tested in several tenants and it acts the same everywhere. Lats time I tested (two weeks ago) it worked fine everywhere. You must have run an update that broke this functionality which is however very important. Can this be repaired please?

moutinhoabreu
Level: Powered On

Re: Output in For a selected item disappears after saving flow

Me too.

I've placed here a screenshot.

Running a flow for a long time, triggered by a sharepoint list and whem i tried to add a second option, it disappears on saving flow.

Cheers

Screen Shot 2018-04-10 at 18.12.00.png

Driede
Level: Powered On

Re: Output in For a selected item disappears after saving flow

Yes. I still have the problem.

 

Steps to reproduce:

  1. Create a flow based on the template "Request manager approval for a selected item" (or create a simple flow using "For a selected item" as the trigger).
  2. Add an output for the "For a selected item" trigger.
  3. Save flow.
  4. Close flow and return to "My Flows"
  5. Edit flow created in step 1.
  6. Output created in step 2 disappears.

 

As I mentioned I used the Request manager approval for a selected item template. The only thing I configured is the trigger. I included a screenshot.

 

template.png

moutinhoabreu
Level: Powered On

Re: Output in For a selected item disappears after saving flow

Despite a different trigger it's exactly what i'm experiencing. 

Already tried to save as.. and try with that new copy. No solution.

Also exported the flow and re-imported. No solution.

 

I'm going to create a ticket on Flow regarding this situation.

 

Please let me know if you find any workaround.

 

Thanks

cheers.

Bixomatic
Level: Powered On

Re: Output in For a selected item disappears after saving flow

I'm having the exact same problem. Thought I was going crazy. Keep me posted on your ticket, if you don't mind!

 

Thanks!

moutinhoabreu
Level: Powered On

Re: Output in For a selected item disappears after saving flow

Another note about this issue.

While creating a new flow to test if the behavior was the same, i've noticed the option to create a dropdownlist is available while editing the existing above flow it's missing.

 

LMA
Level: Powered On

Re: Output in For a selected item disappears after saving flow

I have tested in several tenants and it's all lthe same. They messed it up somehow 😞

LMA
Level: Powered On

Re: Output in For a selected item disappears after saving flow

It seems that Microsoft is rolling out general updates to Flow creating new stuff and messing up existing functionality

LMA
Level: Powered On

Re: Output in For a selected item disappears after saving flow

Seems like this is working again. Thanks for whoever fixed this!

moutinhoabreu
Level: Powered On

Re: Output in For a selected item disappears after saving flow

Just tried out in a flow and after saving is disappearing again.

It's working for your side ?

LMA
Level: Powered On

Re: Output in For a selected item disappears after saving flow

Seriously... I tried in two different tenants where it stopped working and now it is working again as expected. I think MS is rolling out an update and your tenant is not yet processed. Happens all the time. Try again in a couple of days.

Driede
Level: Powered On

Re: Output in For a selected item disappears after saving flow

I just tried on my tenant and it's working!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (4,505)