cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Manarjomar
Resolver I
Resolver I

Parameter at index '0' cannot be converted to URI component.

Hi there,

 

I'm working with powerapp and power automate, so I'm try to update the file propeties with flow, but I don't know what happen, because only need to uptadate a text plain field on SharePoint.

 

This field is set with a variable from the TextInput in PowerApp without extrange characters, and I have this error in Power Automate:

 
InvalidTemplate. Unable to process template language expressions in action 'Actualizar_propiedades_del_archivo' inputs at line '1' and column '2793': 'The template language function 'encodeURIComponent' was invoked with invalid parameters. The parameter at index '0' cannot be converted to URI component.'.
 
I try to find the answer but nothing works, or I don't know how can replicate it in my scenario:
 
Screenshot_3.pngScreenshot_4.pngScreenshot_5.pngScreenshot_6.png
 
Thank you.
 
1 ACCEPTED SOLUTION

Accepted Solutions
abm
Super User
Super User

Hi @Manarjomar 

 

Are you using the correct identifier? Try using the ItemId from previous step Create File.

 

image.png



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials

View solution in original post

4 REPLIES 4
abm
Super User
Super User

Hi @Manarjomar 

 

Are you using the correct identifier? Try using the ItemId from previous step Create File.

 

image.png



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials

View solution in original post

Hi @abm ,

 

OMG!! it's crazy, it works with this simple solution.

 

I didn't see this before... hehehe

 

thank you.

ELL
Frequent Visitor

Hello Guys, 

 

May I inquire the below reason and fix for the below message in Power Automate:

Unable to process template language expressions in action 'la_lang_3' inputs at line '1' and column '2892': 'The template language function 'uriComponent' was invoked with invalid parameters. The parameter at index '0' cannot be converted to URI component.'.

 

I am using Compose, with expression uriComponent(variables('INCLUDED EMAILS')

where 'INCLUDED EMAILS' are bunch of emails and I want it to be in a single line, so I converted it first to uriComponent but got failed.

 

ELL_0-1596897139624.png

 

This is the initial flow screenshot:

ELL_1-1596897237746.png

 

 

abm
Super User
Super User

Hi @ELL 

 

Could you please raise another post for your issue? Also please tag me and I will look into it.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (1,386)