cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Tosyn_88
Helper I
Helper I

Planner Assignee Property does not work

Hi MS Flow Community,

 

Our team has issues with MS Planner which is from an admin level.

 

I wanted to write a workaround flow to help keep track of our Planner task but it seems the column or property for the Assignee does not work.

 

I get this error blow;

{
  "error": {
    "code": "",
    "message": "Schema validation has failed. Validation for field 'Assignments', on entity 'Task' has failed: The assignee id is invalid.",
    "innerError": {
      "request-id": "fd34f8fa-60cf-4528-97c7-650498222018",
      "date": "2018-10-05T12:09:39"
    }
  }
}

Here is a summary of what i tried to create

MS Teams & Planner Flow.JPG

Does anyone know why the 'Assignee' property does not work??

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Tosyn_88,

 

Is the column type of AssignedTo in your SharePoint List Person/Group?

If so, then the Assigned User id should be filled in the Create a task action using AssignedTo Email.

I did a test on my side, it work, as below:

34.PNG

35.PNG

 

Best Regards,

Barry

 

 

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

11 REPLIES 11
v-bacao-msft
Community Support
Community Support

Hi @Tosyn_88,

 

I'm afraid I didn't fully understand the intent of the Flow you created.

Could you provide more details and explanations?

Could you provide a full screenshot of your current configured Flow?

I am curious why you use Get items action instead of Get item after When an item is created.

Could you provide the details of the SharePoint list?

I want to know which output in the SharePoint list is to be populated in the Planner task and the Teams message.

In addition, the error message mentions The assignee id is invalid, please ensure that the content filled into the Assigned User Id is in accordance with the requirements of the Field (The id or email address of the user to assign this task to).

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-bacao-msft

 

Thank you for the follow up, appreciate it 🙂

 

The details of the flow is as follows;

MS Teams & Planner Flow1.JPGMS Teams & Planner Flow2.JPG

 

The SharePoint list is as follows;

MS Teams & Planner Flow3.JPGThe [AssignedTo] can be any variable of members within my team so i cannot assign a direct email as the data varies from task to task.

Hi @Tosyn_88,

 

Is the column type of AssignedTo in your SharePoint List Person/Group?

If so, then the Assigned User id should be filled in the Create a task action using AssignedTo Email.

I did a test on my side, it work, as below:

34.PNG

35.PNG

 

Best Regards,

Barry

 

 

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

GabrielStJohn
Microsoft
Microsoft

Hello, @Tosyn_88!

Thank you for posting on the Flow Community Forum! Have you had an opportunity to apply @v-bacao-msft‘s recommendation to adapt your Flow? If yes, and you find that solution to be satisfactory, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify!

Thank you for being an active member of the Flow Community!

-Gabriel
Flow Community Manager

- Gabriel
Community Manager
Power Automate | Power Virtual Agents
Super User Program Manager



@v-bacao-msftand @GabrielStJohn

 

Thank you both for the swift responses, really appreciate the help.

 

I have tried the solution provided and it failed.  I had yet to offer a response due to me not checking all facets of why it failed due to more urgent work commitments.

 

It seems the issue is around the [user] information from the exchange. The last error i remmeber was "404: Not found" but as i said, i still want to check properly.

 

I will ensure to check the flow again this week and provide a detailed feedback.

 

Thanks, you guys are awesome!

Hi @v-bacao-msft

 

I have tried the steps you advised and the flow failed 😞 

 

Here is the resultMS Teams & Planner Flow4.JPG

 

It seems the issue is around the email section. It does not translate from the sharepoint list to planner.

 

Is there no object to identify a user profile or user email on planner??

 

Output error;

 

 

Body
{
  "error": {
    "code": "",
    "message": "Referenced User or Group (my work email) is not found.",
    "innerError": {
      "request-id": "fe3406a4-91c0-44a7-a1a3-b2e93aa23e99",
      "date": "2018-10-16T13:01:44"
    }
  }
}

Thank you for all the help, super glad with how quick your responses are 😄

 

Hi @Tosyn_88,

 

The error message says "Referenced User or Group (my work email) is not found.", I think it should be that the email address populated here is not a member of the organization.

Please ensure that the Email of AssignedTo saved in the SharePoint list belongs to your organization so that it can be searched correctly.

Take a try and see if issue still exists.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
GabrielStJohn
Microsoft
Microsoft

Hello, @Tosyn_88!

Thank you for posting on the Flow Community Forum! Have you had an opportunity to apply @v-bacao-msft‘s recommendation to adapt your Flow? If yes, and you find that solution to be satisfactory, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify!

Thank you for being an active member of the Flow Community!

-Gabriel
Flow Community Manager

- Gabriel
Community Manager
Power Automate | Power Virtual Agents
Super User Program Manager



@v-bacao-msft

 

Thank's for the follow up. 

 

This particular flow came about as a work-around for another flow which i had originally tried to create.

 

It seems our issue at the moment is searching the correct exchange database.

 

So the original Flow was for to post to MS Teams whenever a new task is created with the details of the task and who it is assigned to by adding prefix of "@"

 

It failed as seen below which was due to the fact that there is no object to identify the variable of the user profile the task is assigned to (I had tried writing one).

 

MS Teams & Planner Flow5.JPG

 

MS Teams & Planner Flow6.JPG

This is the error response;

 

Unable to process template language expressions in action 'Post_message' inputs at line '1' and column '2563': 'The template language expression 'triggerBody()['assignedTo']['user']['displayName']' cannot be evaluated because property 'assignedTo' doesn't exist, available properties are '@odata.etag, planId, bucketId, title, orderHint, assigneePriority, percentComplete, startDateTime, createdDateTime, dueDateTime, hasDescription, previewType, completedDateTime, completedBy, referenceCount, checklistItemCount, activeChecklistItemCount, conversationThreadId, id, createdBy, appliedCategories, assignments'. Please see https://aka.ms/logicexpressions for usage details.'.

After this failed, i then decided to perhaps use a SharePoint list in hopes it would be able to pick out the user variable as well but that also doesnt work 😞 

Hi

 

I have the same problem. However, I'm not sure if it is a Flow bug or a Planner bug because when I'm using planner and I assign a task to someone by typing the name, I have to manually select the user to assign the task. Pressing "enter" does not work. Maybe that is the reason we can't assign tasks to someone starting from a flow. 

 

This is a really blocking issue. Could you please provide a solution for us?

RodolfoMCP
Frequent Visitor

Hello,

 

Did we get any resolution on this?

 

I tried a basic flow, but is giving me issues with the Assignee value.

 

Outlook task assigned to Y user >Create a Task on Planner on X Bucket> Assign to "assigned to" field from Outlook task. Error.

 

If I remove the assigne value, it runs perfectly.

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Top Solution Authors
Users online (933)