cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Populate Excel table in SharePoint from DocuSign Envelope Fields

Hi

 

I'm trying to populate an Excel table in SharePoint from DocuSign Envelope Fields.

 

The connect to DocuSign is fine and it runs ok but doesn't populate the spreadsheet.

 

On checking the flow I get the following in the item field but nothing in the labelled spreadsheet fields

 

{
  "SOLUTION PARTNER""",
  "ACCOUNT MANAGER""",
  "ORGANISATION NAME""",
  "STREET ADDRESS""",
  "CITY""",
  "COUNTY/STATE""",
  "POST CODE""",
  "COUNTRY""",
  "TELEPHONE""",
  "WEBSITE""",
  "INDUSTRY""",
  "EMPLOYEES""",
  "SALUTATION""",
  "CONTACT FIRST NAME""",
  "CONTACT LAST NAME""",
  "JOB TITLE""",
  "TELEPHONE2""",
  "CONTACT EMAIL """,
  "OPPORTUNITY SOURCE""",
  "USE CASE DESCRIPTION""",
  "ESTIMATED ANNUAL SUBSCRIPTION VALUE """,
  "ESTIMATED SEATS""",

 

Can't work out where I'm going wrong.

 

Any advice appreciated

 

Thanks

 

Also I would add screen shots but can't see how......

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Community Support
Community Support

HI @BillRussell,

 

Could you please share a screenshot of your flow's configuration?

Could you please show a bit more about the Excel table in your SharePoint?

Further, could you please show a bit more about the content within the item field that you mentioned? Are they custom fields within your envelope?

 

I have created a Excel table wihtin my SharePoint library and the data structure of it as below:7.JPG

 

 

I have made a test on my side and don't have the issue that you mentioned. My flow's configuration as below:

  • Add a "When an envelope status changes (Connect)" trigger.
  • Add a "Apply to each" action, input parameter set to RecipientStatus dynamic content of the trigger.
  • Within "Apply to each" action, add a "Add a row into a table" action of Excel Online (Business) connector. Source set to SharePoitn site, Drive set to SharePoint library. File field set to my Excel file in SharePoint library and Table field set to Table Name.

Image reference:8.JPG

 

The flow works successfully as below:9.JPG

 

10.JPG

 

 

Please check if the Recipient has filled these field values within the envelope. Please make sure that these fields are set to Required field within your envelope.

 

 

Best regards,

Kris

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Apologies for the slow reply. Your response was extremely helpful - turns out I hadn't put my action within the reply to each stage. It merely followed it so did not work correctly.

 

So thanks - problem solved.

View solution in original post

3 REPLIES 3
Community Support
Community Support

HI @BillRussell,

 

Could you please share a screenshot of your flow's configuration?

Could you please show a bit more about the Excel table in your SharePoint?

Further, could you please show a bit more about the content within the item field that you mentioned? Are they custom fields within your envelope?

 

I have created a Excel table wihtin my SharePoint library and the data structure of it as below:7.JPG

 

 

I have made a test on my side and don't have the issue that you mentioned. My flow's configuration as below:

  • Add a "When an envelope status changes (Connect)" trigger.
  • Add a "Apply to each" action, input parameter set to RecipientStatus dynamic content of the trigger.
  • Within "Apply to each" action, add a "Add a row into a table" action of Excel Online (Business) connector. Source set to SharePoitn site, Drive set to SharePoint library. File field set to my Excel file in SharePoint library and Table field set to Table Name.

Image reference:8.JPG

 

The flow works successfully as below:9.JPG

 

10.JPG

 

 

Please check if the Recipient has filled these field values within the envelope. Please make sure that these fields are set to Required field within your envelope.

 

 

Best regards,

Kris

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Apologies for the slow reply. Your response was extremely helpful - turns out I hadn't put my action within the reply to each stage. It merely followed it so did not work correctly.

 

So thanks - problem solved.

View solution in original post

Anonymous
Not applicable

@v-xida-msft 

 

Is there any way for the flow to update the row as the envelope is completed ?

 

Row is added with details when sent -> column Status updated to "Complete" when the envelope is signed. 

 

 

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (5,009)