cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ctw1991
Frequent Visitor

Populate a Microsoft Word template completing but not changing anything

Hi All,

I've been trying to use the "Populate a Microsoft Word template" connector in power automate. I've done everything correctly and the flow runs fine however when I open the file. nothing has been changed.

 

I've seen people say it doesnt work with templates that are loaded into sharepoint so stored the template in onedrive:

https://powerusers.microsoft.com/t5/Building-Flows/Word-Online-Business-Connector-Populate-a-Microso...

 

I know the limitations on rich text and other controls from here: 

https://docs.microsoft.com/en-us/connectors/wordonlinebusiness/#how-to-create-microsoft-word-templat...

 

So what i've done is created a really simple docx with 2 plain text controls and saved it to my onedrive.

 

I a forms response as a trigger as the input data to the template.

 

when I run it it completes no problems but when I actually open the file it doesn't show anything.

why is that?

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-litu-msft
Community Support
Community Support

Hi @ctw1991,

 

After populating these date into the Word template, you should use the generate file content to create a doc file:Screenshot 2021-01-13 151302.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-litu-msft
Community Support
Community Support

Hi @ctw1991,

 

After populating these date into the Word template, you should use the generate file content to create a doc file:Screenshot 2021-01-13 151302.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

walter_pixelia
Frequent Visitor

Hi Lin,

I'm in trouble because if I open the result file through Teams or Sharepoint I can see the fields filled with data, but If I open it in the Desktop App I see again only the fields names. It is a very strange behaviour. Also if I download the file from Teams (.../Download) the file downloaded miss the fields data.

Immagine 2021-03-03 153054.png

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Users online (18,538)