cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
briceeverrett
Helper I
Helper I

Populating Word Template

I am having issues with the "Populate a Word Doc" flow and have searched throughout the board and followed all the tips and tricks to no avail.  Here's what I am working with:

 

Word doc (saved as .docx) with text only controls, created on a MacBook Pro running the latest version of Office365 and macOS 10.4.5

Have saved the doc in both SharePoint Online and OneDrive for Business

Have tried creating a Flow with other templates, saved as .docx with plain text controls created on Windows machines

 

In every single case, I am continuing to recieve the "Error executing the api '/api/templates/schema'" error. 

 

At first I thought it was because the file was saved in a SharePoint library, but moving to OneDrive had no effect.

I also though it was because it was created on a Mac, but that doesn't seem to matter either.

 

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Brad_Groux
Community Champion
Community Champion

This is almost certainly a formatting error within the file itself. A user had a similar issue within this post and it turned out to be:

The issue was the links in the Word document had been created using the document properties as opposed to the button on the developer tab.

To test if it is the formatting, I would create the the Word document template directly from a SharePoint Online Document Library, like so:WordDocumentFromLibrary.png

When creating templates, it is important to create the controls from the Developer tab/menu. Also, Microsoft provides an Easy fix tool for templates that may be of some use. NOTE: THE TEMPLATE FILE CANNOT BE CREATED ON MAC / OS X. 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

4 REPLIES 4
Brad_Groux
Community Champion
Community Champion

This is almost certainly a formatting error within the file itself. A user had a similar issue within this post and it turned out to be:

The issue was the links in the Word document had been created using the document properties as opposed to the button on the developer tab.

To test if it is the formatting, I would create the the Word document template directly from a SharePoint Online Document Library, like so:WordDocumentFromLibrary.png

When creating templates, it is important to create the controls from the Developer tab/menu. Also, Microsoft provides an Easy fix tool for templates that may be of some use. NOTE: THE TEMPLATE FILE CANNOT BE CREATED ON MAC / OS X. 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Following these instructions, I've created a Word Doc in the document library, opened in the desktop app on Mac, and inserted a single field from the developer tab.   Even with this super simple document, I am still receiving the error.

 

Screen Shot 2019-08-23 at 4.25.32 PM.png

 

Hi @briceeverrett ,

 

I am currently unable to determine if this is related to the operating system.

Have you tried creating a Word Template on a PC with a Windows operating system and uploading it to SharePoint Library or OneDrive?

I did a test on my side and this feature is working.

26.PNG

Please also check this similar thread and see if it helps:

https://powerusers.microsoft.com/t5/Building-Flows/Word-Online-Business-Connector-Populate-a-Microso...

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

It seems to be an issue with using Word for Mac to create the document.  I was able to grab a PC and create a test doc in the same folder that works just fine.  I know that the connector is in preview but I am hoping that this gets worked out soon!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Users online (2,271)