cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JacoJoubert
Frequent Visitor

Power Automate - Create a SharePoint list item when a Teams message is posted

Hi Community

 

I would like to create a SharePoint list item when a new Microsoft Teams message is posted in a specific channel.

I created a SharePoint list with a couple of columns including a "Multiple lines of text" column type with "Enhanced rich text (Rich text with pictures, tables, and hyperlinks)" enabled for the Teams message body called "Request Description". 

 

I am able to create a new SharePoint list item when a new Teams chat is created, but the "Request Description" column only contains the text of the message and does not include any images (it does, however, look like it has a placeholder, but the image does not display).

 

Any assistance would be appreciated.

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Rahber
Super User II
Super User II

This is because in the body content the image in teams is referenced as <attachment id="GUID"></attachment>

This will not work in sharepoint as the attachment is not parsed there.

You should look for contentURL value that will have the image URL directly but it will still not display as this image is hosted in Teams File folder so if you are not authenticated in that browser it will show empty. You will need to modify SharePoint settings to view them.

 

Please click Accept as Solution if it resolved your problem or give it a Thumbs Up if it helped you in anyway this will allow other people to search correct solutions effectively.

Thanks,
Rahber

View solution in original post

2 REPLIES 2
Rahber
Super User II
Super User II

This is because in the body content the image in teams is referenced as <attachment id="GUID"></attachment>

This will not work in sharepoint as the attachment is not parsed there.

You should look for contentURL value that will have the image URL directly but it will still not display as this image is hosted in Teams File folder so if you are not authenticated in that browser it will show empty. You will need to modify SharePoint settings to view them.

 

Please click Accept as Solution if it resolved your problem or give it a Thumbs Up if it helped you in anyway this will allow other people to search correct solutions effectively.

Thanks,
Rahber

View solution in original post

@Rahber thank you for your response. I understand now why this is not working. Do you have any suggestions on how to authenticate the request to Teams?

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (58,786)