cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
clem_581
Frequent Visitor

Power Automate can not send an UI-Flow (Webflow) to the On-Premise Data Gateway

I built a simple UI-Web-Flow to get the temperatur of my city.
I now inserted the UI-Flow to a regular flow, downloaded the On-Premise Gateway, set up a new Profil and inserted the credentials to the regurlar flow. Now when I start the regular flow, I just get an error.
can anyone tell me how I should start fixing this problem?

 

Thank you!

11 REPLIES 11
ChristianAbata
Community Champion
Community Champion

hi @clem_581  what is your error?



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

I get this error message:

 

A connection to the Power Automate agent for UI Flow could not be established. Ensure that the local data gateway and the Power Automate agent for UI flows are running and the connection parameters for UI flows are configured correctly.

 

But I don't know what to do with it

UIIt is an UIFlowsAgentCommunicationFailure

hi @clem_581  ok is like your credentials are invalid, or sometime if your machine is on enterpise domain there are rules that not allow to conect your pc by gateway.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

I already checked my credentials, they should be the same in Power Automate as well as in the gateway...
I installed the Gateway on my personal mashine

when I search for my username in cmd, I get this result:

 
 

image.png

is the the username and domain I must enter in the Data Gateway?

@clem_581  please try to uninstall your gateway and install again.  I tested my flow UI into Virtual Machine with no problems.

 

Please see the troubleshooting doc https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-tshoot to see if one of the escenarios presented are not yours.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Is this my domain and username?

image.png

Or is my domain and username from the cmd above?

 @clem_581  yes friend it is.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Can you verify if the gateway is online? 

In the left nav bar, go to  data->Gateways. Select the gateway. click on ... next to the name and go to details page. It shows whether the gateway is running or offline 

 
 
 

Yes it is online, still not working

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (3,446)