cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Syndicate_Admin
Administrator
Administrator

Power BI Machine Learning, using Data flow (via gateway) error

Hi,

 

I am tryng to train a model from a data flow, data flow created on top of SQL Server database using gateway, it refreshed fine on it's own, but when I add a machine learning model (binary prediction), it does not refresh and producs error.

 

An error happened while reading data from the provider: 'Error from AutoML: Error occurred while training AutoML Model'

 

any help owuld be appricated.

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

I had a conversation with Microsoft people working on it, you need to update the gateway to new relased version, as this is the fucntion they included in the new gateway, they also processing a new update at backend of it.

 

While it resolves the above issue, there is another problem,  it is not showing summary report of processed model, it tries searching for it for ages and then comes up with the message that it cannot find it...

View solution in original post

4 REPLIES 4
Syndicate_Admin
Administrator
Administrator

I had the same issue and my refreshes kept failing subsequently after building a model.

I looked at the error and mine stated that the credentials were invalid. After going back into the settings of the dataflow, I re-entered the credentials which seemed to resolve the issue for now. I have noticed that AutoML within PBI has been spotty with its refreshes.

 

Hopefully that resolves your issue and you're able to refresh from there.

Thanks for your reply, already did that few times for no joy, below is the error we getting when trying to refresh it, in one of the training model created on top of data flow from Power BI, any help would be appreciated.

 

We encountered an error during evaluation. Details: The name 'AI.SampleStratifiedWithHoldout' wasn't recognized. Make sure it's spelled correctly

 

 

Thanks

Syndicate_Admin
Administrator
Administrator

I'm also having this issue. Only affecting Binary because of AI.SampleStratifiedWithHoldout function issues

I had a conversation with Microsoft people working on it, you need to update the gateway to new relased version, as this is the fucntion they included in the new gateway, they also processing a new update at backend of it.

 

While it resolves the above issue, there is another problem,  it is not showing summary report of processed model, it tries searching for it for ages and then comes up with the message that it cannot find it...

View solution in original post

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (31,208)