cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Elliott57
Microsoft
Microsoft

Predict attachment /w AI Builder (Form Processing)

 

Hi, 

 

I'm trying to create Power Automate flow. 

 

1: When an email arrive check attachment 

2: Predict (Ai builder), attachment .. but I doesn't work... (Document type : Attachment type and Document : Attachment content)

 Do you know what is the issue ? 

Predict issue.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
yashag2255
Dual Super User II
Dual Super User II

Hi @Elliott57 

 

You need to add the Get Attachment content action before the Predict action and then pass that content in the Document field in the predict action. 

 

Can you try adding this and check if it resolves the issue? 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

4 REPLIES 4
yashag2255
Dual Super User II
Dual Super User II

Hi @Elliott57 

 

You need to add the Get Attachment content action before the Predict action and then pass that content in the Document field in the predict action. 

 

Can you try adding this and check if it resolves the issue? 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Hi Yashag, 

 

It works, but now the problem is on the condition 😞 Do you have an idea ? 🙂

 

condition.PNGinvalidtemplate.PNG

Hi @Elliott57 

 

Yes. So for some reason, the flow reads the balance output as an object. Can you add a compose action and add the balance to that and run the flow. In the flow history, check what value is being returned in the compose action? 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi,

 

Just found the problem. My bad I didn't well parameter the conditional control !

 

Thank you for your help 🙂 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (39,265)