cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DA Advocate III
Advocate III

Problem create record in CDS with lookup field

I try to create an record in the product entity with flow.
No matter what i provide for the Category name field (Name, Record ID, primary id), it results in the same problem.
The  Categoryid field is alwyas null.
Waht value must i provide for a lookup field?
 
i have following product categories:

product categorie.PNG

Data passed to cds in flow:

id.PNG

 

results in error mandatory fiels missing (is not passed form the flow):

proderros.PNG

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
DA Advocate III
Advocate III

Re: Problem create record in CDS with lookup field

I did not really solve this problem.

For this special case i created a Custom Entity without lookup filed.

 

This not a real solution for the problem.

 

Hoefully there will be a way to provide lookup values in dynamic content in the future.

View solution in original post

3 REPLIES 3
Community Support
Community Support

Re: Problem create record in CDS with lookup field

Hi DA,

 

This issue can be reproduced from my side. I created a flow to create a record in CDS Product entity when an item is created in SharePoint list. When the flow ran, I got the same result with you.

product1.PNG

product2.png

 

It seems that there is no available dynamic content can be selected for Category name field. I opened this entity in Excel, and I found that this field need Category ID, Category name, Description. But there are no dynamic content can be selected.

product3.PNG

 

Thanks for you feedback. I will report this from my side, and try to involve others to take a further investigation.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
DA Advocate III
Advocate III

Re: Problem create record in CDS with lookup field

I did not really solve this problem.

For this special case i created a Custom Entity without lookup filed.

 

This not a real solution for the problem.

 

Hoefully there will be a way to provide lookup values in dynamic content in the future.

View solution in original post

Community Support
Community Support

Re: Problem create record in CDS with lookup field

Hi DA,

 

I have reported this from my side. I think PGs are looking into this issue.

 

Thanks for your patience and understanding. I will back once I got any updates for you.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Users online (6,918)