cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Problem using IF expression to display a from field value if the value of another form field is equal to Yes.

Hello,

 

I've built a flow to send an Outlook email populated with data from a MS form submission. However, in the email I'm trying to use the IF expression to show the value of a form field only if the value of another form field is "Yes."  Here is the expression that I have so far...

 

if(equals(body('Get_response_details')?['r9f898a6597024b03989b9f5d13d5b357'],'Yes',body('Get_response_details')?['r346258161c974bd1b6faf5ecc9d12c7b'],'')

 

I've gotten the expression to work if the true condition value is static text but it keeps coming back as invalid when I try to make the true condition value another form field. I think my syntax is off but I don't know the correct format. Can anyone advise me of the correct format? I'm hoping it's something simple. Thanks.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Re: Problem using IF expression to display a from field value if the value of another form field is equal to Yes.

Hi @jpalmarozzo ,

 

Please try to format the function likes below:

if(equals(body('Get_response_details')?['r0c350344c2234ed987316af96bee974c'],'Yes'),body('Get_response_details')?['rb4dac56b277b41dd874addc4d62539c1'],'')

 

I have made a test and it is just working fine.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support
Community Support

Re: Problem using IF expression to display a from field value if the value of another form field is equal to Yes.

Hi @jpalmarozzo ,

 

Please try to format the function likes below:

if(equals(body('Get_response_details')?['r0c350344c2234ed987316af96bee974c'],'Yes'),body('Get_response_details')?['rb4dac56b277b41dd874addc4d62539c1'],'')

 

I have made a test and it is just working fine.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (5,201)