cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RobWickham
Advocate III
Advocate III

Problem with Get File Properties losing data after using Send HTTP Request to SharePoint for the same Filename ID

I originally posted this under Ideas, because I assumed it was part of a larger issue of functionality. I'm duplicating the issue here for insights and workarounds, or at least validation that it's not just me.

 

--------------------------

 

I use a Get File Properties, followed by a Send HTTP Request to SharePoint. I do this in order to obtain all the file properties, including the moderation status (not supported by get file properties).

 

Unfortunately, this seems to be causing some important file properties to no longer be accessible in my subsequent flow steps.

 

Having to place the ones I care about into separate variables as a workaround is really lame.

 

Here are the file properties, and the ones with an 'x' in front are the only ones available after the send http request to sharepoint for that same filename id. the ones in bold are "lost".

 

body
checked out
checked out to

x checked out to claims
x checked out to department
x checked out to display name

checked out to email

x checked out to jobtitle

checked out to picture

x comments associated with the content approval
x compliance asset id
x content approval status

created
created by

x created by claims
x created by department
x created by display name

created by email

x created by job title

created by picture

x file name with extension
x folder path

ID

x identifier

isfolder

x item is a record
x link to item

modified
modified by

x modified by claims
x modified by department
x modified by displayname

modified by email

x modified by jobtitle

modified by picture

x name

shared with

x shared with claims
x shared with department
x shared with details
x shared iwth displayname

shared with email
shared with item

x shared with jobtitle

shared with picture
thumbnail

x thumbnail large
x thumbnail medium
x thumbnail small
x title
x verison number

 

Is my analysis correct, that this is a problem with using these two actions with the same filename id, or is something else going on?

 

The "Idea" is here:

 

https://powerusers.microsoft.com/t5/Flow-Ideas/Get-File-Properties-Lost-Impacted-by-using-Send-HTTP-...

 

2 REPLIES 2
v-litu-msft
Community Support
Community Support

Hi @RobWickham,

 

Could you please share how do you configure the Send http request to SharePoint action?

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Lin Tu, here is the setup I have. The problem is evident when I attempt to configure an action that takes place subsequent to the http request action. The "set variable Last Modified" action is the workaround to capture this particular property before the http request removes it from the visible property list.

 

http request issue for get file properties.PNG

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,969)