cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Teflonreis
Helper I
Helper I

Problem with Sharepoint list: create item and add attachment

Hello everyone

 

If an item is created in the secondary list, the primary list shall also be populated with the row including attachments.

The flow works. What does not work yet is copying the attachment from secondary to primary list.

Copying does work if the user field in "create item" is not populated with "user displayname" since apply to each with "user" is built around "create item". Because of "apply to each", the action "add attachment" only displays the wrong id. "add attachment" only worked so far when I use the id "create item".

 

I am wondering how to populate the field "user" with "user displayname" in "Create item" such that no apply to each is built around it which would result in "add attachment" not displaying the "id" from "create item".

 

Thanks for any help.

 

 

Teflonreis_0-1666782558867.png

 

 

Teflonreis_1-1666782568991.png

 

 

 

Teflonreis_2-1666782578287.png

 

An idea.

Is it possible to write out the suggested dynamic content that IS NOT displayed in ADD ATTACHMENT?

"id" inside "create item" inside "apply_to_each". Something like this ? items('apply_to_each')?['id']

 

 

 

0 REPLIES 0

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (4,502)