cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ivo-hora
Frequent Visitor

Problem with startswith filter in CDS List records

I've been experiencing an issue (although I may just be doing it wrong). I'm building a flow that uses a List Records action from the 'Common Data Service (current environment)'. The idea is that we're listing all the campaigns in dynamics with an actual start of today. However, when testing the flow (with a button) I keep getting an error. The flow looks like this: 

ivo-hora_0-1602600819122.png

 

The expression used in the filter is: formatDateTime(utcNow(),'yyyy-MM-dd') 

 

The following is the filter query when testing:

ivo-hora_0-1602600391101.png

And the error I get is the following: 

ivo-hora_1-1602600440562.png

 

I can't figure out what I am doing wrong. Does anyone have an idea how I can execute this, or an alternative for filtering my list records action on today?

 

Thanks! 🙂

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Pstork1
Dual Super User III
Dual Super User III

StartsWith() requires that both fields being compared are strings, but I'm assuming that actual start is a date.  You'll need to use a formatDateTime on actual start just like you do for UTCNow.  Of course if you do that its probably easier to just use equals



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

2 REPLIES 2
Pstork1
Dual Super User III
Dual Super User III

StartsWith() requires that both fields being compared are strings, but I'm assuming that actual start is a date.  You'll need to use a formatDateTime on actual start just like you do for UTCNow.  Of course if you do that its probably easier to just use equals



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

ivo-hora
Frequent Visitor

@Pstork1 Thanks, this helped :)! I just added a Condition, in which I formatted both the actual start and utcNow in the same format, and that worked.

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Users online (42,200)