cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PengoFant
Regular Visitor

Problems with creating Customer Voice Surveys with Power Automate

Hi all, hopefully someboy can help here.

 

I am trying to generate new customer voice surveys (used to be called Form Pro) from power automate using the Create Record action (Common Data Service).

 

It works in the way that I am able to create bot Custome Voice Projects, Customer Voice Surveys and Customer Voice Survey Questions.

I can confirm that these records exsist by doing a Get Record / List records (these actions confirms that the records are created).

 

This is great except for one problem, when I go to

https://customervoice.microsoft.com/Pages/ProjectPage.aspx#

 

I am not able to see the survey I created? Even though they are created they are not visible?

 

Is there some flag or something else that I am not setting? It is frustrating and I have been trying eveything I can think of to fix it.

 

Hope somebody has some input, thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
ManishJain
Solution Sage
Solution Sage

@PengoFant , the connector is connecting to update data in CRM and not forms so I believe there might be work in progress for this to update data in Forms as well . Please raise your idea.

 

Thanks

View solution in original post

10 REPLIES 10
ManishJain
Solution Sage
Solution Sage

@PengoFant , Are you trying to create new project and new survey inside that project or you are trying to send survey which lies inside one project . Please clarify.

 

Thanks

@ManishJain I am trying to create a completely new survey (either in an existing project or also creating the project).

For testing purposes I tried changing a survey question using the Common Data Service Update Record action but was not able to see anything change when I look in the Customer Voice website.

The strange thing is that I can see the changes in what is returned when doing a Common Data Service Get Record but not on the website.  

ManishJain
Solution Sage
Solution Sage

@PengoFant , This is my understanding that you can update survey questions and get response back as that survey and question are residing in D365 which is not directly updating it back to Forms. I could be wrong here but I dont think channel works both ways it is only from forms to D365.

 

Thanks

PengoFant
Regular Visitor

@ManishJain OK, thanks for taking the time to weigh in.

Based on testing it out it seems your are right. It is a shame, it would be an awesome feature to be able to create new surveys from power automate.

ManishJain
Solution Sage
Solution Sage

@PengoFant , the connector is connecting to update data in CRM and not forms so I believe there might be work in progress for this to update data in Forms as well . Please raise your idea.

 

Thanks

View solution in original post

& @PengoFant , I recently was trying to do something similar, but I am only creating the Customer Voice survey question response record based on context data in a power automate after a survey is submitted. 

 

Everything looks good in the CDS and the basic model driven app when comparing the question responses submitted via the actual survey. However, none of the responses are showing up in the customer voice reports for the survey.

 

From your conversation, it looks like there are actually 2 different data sets then. The CDS data set and then a different dataset in forms that the reports use. When a survey is submitted it logs the information in forms and a copy in CDS. If either this was bi-directional or if forms just used the CDS tables, this would not be an issue. 

 

Luckily, we plan to just pull the data from the CDS into powerBI to create our own reports. 

ManishJain
Solution Sage
Solution Sage

@MMH117 ,

 

Have you tried to set up the metrics first in order to see those ? 

 

Thanks

Sorry. I should have said reports instead of metrics.

 

I can see the information context data in the personalized data tab of the survey responses, but the questions which I am generation in CDS from this data are not showing up in the reports within customer voice.

 

Yesterday, I found in the documentation a diagram which shows how the data actually splits into the customer voice analytics engine and the CDS. This re-enforces why the questions I am creating in CDS do not show in the reports section of customer voice. 

 

https://docs.microsoft.com/en-us/dynamics365/customer-voice/data-flow

ManishJain
Solution Sage
Solution Sage

Hi @MMH117 ,

 

I was referring to creation of metrics in Customer voice based on type of questions you have set up in your surveys. Following blog gives a better explanation of how to set up metrics in Customer voice:

 

https://meganvwalker.com/overview-of-satisfaction-metrics-in-d365-customer-voice/

 

Thanks

@ManishJain I understand. That is why I mentioned I should have said reports instead of metrics. 🙂

 

Also, Megan Walker's website has been a great resource. I highly recommend it too. 

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (74,324)