cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Question about conditions

Hi,

 

I am new to this and I have create a very simple flow, about adding a To-Do task based on certain criteria when an email arrives.

 

My problem is with the Condition below. Basically I want to do nothing if the email is from a certain sender, and the body contains a specific text.

 

However the condition only seems to work if it resolves to 'Yes'. If it resolves to 'No', I get an 'ActionFailed: An action failed. No dependent actions succeeded' error. 

 

I hope someone can point me in the right direction, thanks in advance!

Flow 1.pngFlow 2.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

Re: Question about conditions

Hi @paulnerie, even though the error will be displayed on the condition, the actual error is being thrown by your To-Do action. Are you able to share the configuration of that action please?





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

View solution in original post

6 REPLIES 6
Highlighted
Super User III
Super User III

Re: Question about conditions

Hello,

What is the exact error when the flow fails? I ask this because there must be a reason for the failure.

As a workaround you could try and set the action in the ‘No’ using configure run after.

This can be done by clicking the 3 dots on the action in the ‘No’ shape and selecting configure run after. Click the box that says Failed.

This means that even if the action above has failed, the workflow will still attempt to execute.

Again this is just a workaround, and we should try and see why it’s failing when the condition is No/false

--Josh

If you like my post please hit the "Thumbs Up" -- If my post solved your issue please "Mark as a Solution" to help others




Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips, tricks, and guides
FlowAltDelete




Highlighted
New Member

Re: Question about conditions

Hi Josh,

 

Thanks for the quick response.

 

Below is the only error message I see. Is it possible to see a more detailed info?

 

Also the 'Configure run after' option is disabled.

 

Flow 3.pngFlow 4.png

Highlighted
Super User
Super User

Re: Question about conditions

Hi @paulnerie, even though the error will be displayed on the condition, the actual error is being thrown by your To-Do action. Are you able to share the configuration of that action please?





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

View solution in original post

Highlighted
New Member

Re: Question about conditions

Hi @MattWeston365,

 

Thank you.

 

Below is the configuration. This worked before I added the condition, as I wanted to filter out some emails.

 

It's weird that the error shows up in the condition instead on the actual action itself.

 

But I'll add the same action on the parallel branch and see if it still works without the condition.

Flow 5.png

Highlighted
New Member

Re: Question about conditions

Hi @MattWeston365,

 

Your post pointed me to the right direction :).

 

I had an error in the formula, that I only saw when I tested the action out of the condition.

 

I hope Microsoft fixes this so that the error shown is actually in the action, and not in the condition. Or show them on both.

 

Thanks again!

Highlighted
Super User III
Super User III

Re: Question about conditions

Glad you were able to fix the problem.

You can see the error in the failed run if you click the ‘To Do’ action the error will be there

--Josh

If you like my post please hit the "Thumbs Up" -- If my post solved your issue please "Mark as a Solution" to help others




Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips, tricks, and guides
FlowAltDelete




Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (7,536)