cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Receiving 404 Error while Updating a record in D365FO through flow.

Hello Everyone,

I have created a flow to update an entity in d365 operations but my flow is failing with a 404 status.(NotFound.) Just to be sure i used a get record action to see if the record exist or not. I can retrieve the record as well as delete the record using the same Object ID. I can also insert a new record in the entity. I am only getting this error while trying to update a record. Below is the detail body of the response. Can anyone help me with what am i doing wrong? Thanks in Advance.

 

Capture31.PNGCapture33.PNG

 

 

{
  "status": 404,
  "message": "NotFound\r\nclientRequestId: 1079a023-7612-4215-8621-4ed8f7e1519e",
  "error": {
    "message": "NotFound"
  },
  "source": "xyz.cloudax.dynamics.com",
  "errors": []
}

 

 

 

5 REPLIES 5
Highlighted
Dual Super User
Dual Super User

Re: Receiving 404 Error while Updating a record in D365FO through flow.

Hi @ZoarderMuttakin 

 

Are you updating the record that you are getting in the previous action or the one that is triggering the flow? Can you try passing the object ID from the outputs of these actions directly and check if that resolves the issue? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
New Member

Re: Receiving 404 Error while Updating a record in D365FO through flow.

hello @yashag2255 , Thanks for your suggestion. I have tried both ways and its still not working.

Highlighted
Community Support
Community Support

Re: Receiving 404 Error while Updating a record in D365FO through flow.

Hi @ZoarderMuttakin ,

 

I see the Get record action run successfully in the screenshot, and the Object id field in the Update a record action and the Get a record action should be same, could you please just enter the same Object id in the Update record action the same as the Object id in the Get a record action?

1.png

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted
New Member

Re: Receiving 404 Error while Updating a record in D365FO through flow.

Hello @v-alzhan-msft, i have used the same object id in both the actions.

Highlighted
Dual Super User
Dual Super User

Re: Receiving 404 Error while Updating a record in D365FO through flow.

Hi @ZoarderMuttakin 

 

Can you share a screenshot of the flow in edit mode for all the actions? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (7,564)