cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Falls
Frequent Visitor

Record Identifier missing from dynamics content (Dynamics 365)

Hi,

For over 2 days now, I have been working on a new approval flow when a new Dynamics 365 (not Dynamics CRM) record is created during a PowerApps Business Process stage but I am not getting anywhere. Kindly note that the Business Process Flow appears to work fine. I have tried to develop the approval flow using templates and from blank but have encountered problems on both account. One of my problems is that I cannot find where the Record Identifier (please attachments) comes from since it does not show or appear on my dynamic content list of items or components (giving me the impression that I must be doing something wrong or my settings on the environment are not correct). Unless I am mistaken, I would have thought that the Record Identifier should automatically show on the dynamic content (similar to Organisation Name and Entity). Secondly, when I use (Deprecated) Stage Id for Record Identifier (or any other elements from the available dynamic content), the approval flow run fails naturally or a completely new record is created which is different to the record that I have started in a PowerApps Business Process Flow. The main idea of the flow is to get approval via PowerApps Business Process Flow for next stages of the business. I would be ever so grateful if someone can tell me where I am going wrong or suggest a working solution to this problem.

Thank you so much for your time.

 

Falls

Dynamics 365 (record create set OK)Dynamics 365 (record create set OK)Dynamics 365 (Record Identifier) not on dynamic contentDynamics 365 (Record Identifier) not on dynamic content

 

2 REPLIES 2
yashag2255
Dual Super User II
Dual Super User II

Hi @Falls 

 

Please have a look at the flow: The record Identifier is a unique Id of the record that is created. (it is unique across all records). Type id in the dynamic selector and select the identifier from tha results:

jssja.png

Ensure that you are connecting to the same etity and organization in both the action and the trigger. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Falls
Frequent Visitor

Thank you for the reply. I have gone over the dynamics content and looked / searched for anything that could give me some kind of unique identity (record or entity) but found nothing. I am not sure if my entity settings are inhibiting the information that I need. Will take a second look at that again.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (1,346)